Welcome to OpenFX Online Help

Ajuda referencial do Designer


How to Use This Function Reference

Como usar esse manual de referência rápida

Esse manual tem como objetico dar uma referência do trabalho no OFX a novatos e experientes usuários. Para encontrar a função procurada, note o menu onde algumas opções aparecem, e procure nos sub-menus o conteúdo.

Todas as funções são listadas em ordem do menu, da esquerda para a direita e do alto para baixo. O layout geral, ícones e ferramentas são listados no início da seção de cada módulo, depois dos menus.


Termos usados no Designer

Cursor3D - Um programa bidimensional possui um único cursor, mas quando trabalhamos no espaço 3D precisamos de um cursor adicional que possa trabalhar nas três dimensões espaciais. Ele pode ser colocado em qualquer lugar do espaço 3D com o ponteiro do mouse.

Janela ativa - É a vista que está atualmente em foco. Ela é iluminada por um contorno amarelo. Pressione Tab para caminhar pelas vistas, clique com o mouse numa vista para torna-lá ativa.

Ponto pivô - Cada modelo tem um ponto usado no animador para manipular o modelo. Por exemplo se um modelo for uma aeronve seguindo um caminho o ponto do modelo que exatamente segue o caminho é o ponto pivô.

Curva - Um conjunto de vértices concectados por arestas sem formar nenhuma face. Curvas podem ser abertas ou fechadas.

Centro de massa - O mesmo que centro de gravidade de um objeto. Onde sua massa é maior. E diferente do ponto pivô e do ponto perseguidor. O centro de massa pode ser usado com extensões que simulam efeitos físicos nos objetos.

Aresta - Um seguimento de reta conectando dois vértices.

Face - Uma superfície triangular definida por 3 arestas unidas exatamente por 3 vértices .

Ponto perseguidor - Uma localização (Especificada no Designer) no modelo onde outro objetos podem seguir.

Quadro - Igual a convenção cinematográfica de quadros para cinema e animação. Pode ter imagens em seguência na proporção por exemplo de 24 quadros por segundo. Cada quadro é composto de uma imagem.

Matiz Plástico - Um algorítimo de renderização que sombrea o modelo misturando e desfocando superfícies adjacentes. É usado pela vista OpenGL.

Mapeamento imagem - Um mapeamento imagem é um arquivo GIF ou TGA que será usado para "pintar" faces do modelo adicionando decalques detalhados na superfície.

Indicado - Para escolher um particular vértice, aresta, face, ou objeto para ser afetado por uma operação sem seleciona-lo coloque o Cursor3D sobre ou próximo a ele (entre um ou dois "pixels") para ser indicado. se mais de um elemento está indicado então o mais próximo do cursor3D será usado.

Modelo - É unidade principal da estrutura. Um modelo é feito por faces e cada face é determinada por três arestas. O tamanho, posição e orientação da face é determinada pelos vértices que a definem.

Chaves de modificadores - O Shift, Ctrl e Alt são usados para modificar a ação das ferramentas do Designer. Se um ou outro é usado então a ferramenta é modificada apropriadamente.

Morfose - Proporciona que um modelo se transforme em outro.

Nó - Um nó é um ponto em um caminho ou robô que pode ser manipulado. E representado por um pequeno quadrado.

Origem - A origem padrão são as coordenadas de valores (0, 0, 0).

Caminho - Uma Curva que é usada no Animador como caminho para os atores seguirem (.PTH). E pode ser usado no Designer para definir uma extrusão.

Matiz esmalte - Um algorítimo de renderização que sombrea um modelo suavizando e descreve superfícies, texturas e propriedades de reflexão e pode simular espelhos. O Render usa essa matiz como padrão se o raytrace não estiver ativo.

Suavizar - Esse é um procedimento que ajuda a remover a aparência facetada da superfície de um modelo.

RayTrace - Um complexo sistema de renderização capaz de criar efeitos espelho, transparências, sombras, e refrações.

Status da Seleção - Cada vértice no modelo pode ter um desses estados: Selecionado, Deselecionado, Oculto. Selecionado vértices são manipulados pelas ferramentas e ações. Deselecionado Vértices não são afetados pelas ferramentas ou ações. Oculto vértices não são exibidos e não são afetados.

Textura - Uma textura é um algorítimo que pode adicionar finos detalhes a superfície do modelo. Exemplos são madeira e Mármores. Eles não dependem de uma imagem pois são gerados matematicamente.

Esqueleto - O esqueleto e os nomes hierárquicos são a mesma coisa. O esqueleto é um termo usado para facilitar a compreensão do sistema de vértices que podem deformar partes de um modelo.

Ligação do esqueleto- O esqueleto é formado por um número de ligações, cada ligação tem um Osso associado e um nó no seu fim. Cada osso é amarrado a outra articulação no nó ou "raiz".

Intensidade de brilho - O polimento de uma superfície é simulado pela intensidade de brilho. Basicamente quanto mais polida uma superfície maior será a intensidade de brilho que ela possuirá.

Vértice - Um ponto distinto no espaço 3D representado por um ponto amarelo ou vermelho se selecionado ou deselecionado respectivamente.


Quad View

Quatro vistas

As três vistas com botões nomeados com Superior, Anterior e Lateral são as vistas usadas para o trabalho. Esses botões quando clicados alternam para a Vista simples, útil para editar de forma mais refinada. Vc pode Redimensiona as quatro vistas Clicando na interseção das vistas.

A vista Câmera exibe a perspectiva renderizada do modelo via OpenGL.

A barra de status na parte inferior tem dicas para cada operação no Designer. A parte da barra a direita mostra o número de vertices e faces selecionados.


Single View

Vista Simples

Exibe a vista com uma janela bem larga.

Pressionando no botão da vista ativa irá fazer o Designer voltar as Quatro Vistas . Opções para alternar estão em Janela > Quatro vistas ou usando shift + F4.

Para exibir uma vista simples das outras vistas, pressione os botões correspondentes.

Usar a vista simples é muito útil para visualizar melhor o objeto, e principalmente para editar o mesmo. Como vc poderá reparar, nas quatro vistas quando um objeto é ampliado e suas dimensões ultrapassam os limites das janelas, partes dos mesmos podem tornar-se invisíveis, o que na vista simples não acontece.


Resize Quad View

Redimensionar as vistas

As vistas do Designer podem ser dimensionadas arrastando a interseção entre elas conform ilustrado:


Camera View

Vista Câmera

A Vista Câmera exibe uma renderização tridimensional do modelo. É a mesma janela do OpenGL.

Para ver o modelo por diferentes ângulos, pressione o botão esquerdo do mouse (o cursor se transformará em uma mão) na vista e mova para a posição desejada.

A vista câmera usa por padrão a renderização OpenGL. Para torna-la mais ligeira pressione F11 ou clique com o botão direito na vista para acessar as opções.

Veja mais em:
Não Exibir Linha Oculta
Renderização rápida


OpenGL Shaded view

Vista sombreada - OpenGL

A Câmera OpenGL exibe uma rederização sobreada (Com ou sem mapeamento).

Pressionando F11 ou clicando com o botão direito do mouse na vista escolhendo Ocultar/Exibir Câmera OpenGL vc desliga o sombreamento.


OpenGL Shaded with Wireframe Overlay View

Vista OpenGL com cobertura de malha

Além da representação sombreada do objeto essa opção mostra também a malha do objeto.

Essa opção é ativa acessando o menu Vista OpenGL > Cobertura de malha ou clique direito na vista e escolhendo o item Cobertura de malha no menu flutuante.


OpenGL Preferences

Preferências da OpenGL

A caixa de diálogo OpenGL possibilita vc selecionar as propriedades da Câmera OpenGL. Acesse o comando Vista OpenGL > Preferências.

Matiz plana das faces - Renderiza o modelo sem suavização das faces.

Usar mapeamento de imagens - Renderiza o modelo com os mapeamento aplicados.

Usar malha quando manipular janela - Altera a representação do modelo para mostrar apenas as arestas quando usar o mouse para maniplula-lo, mais veloz.

Malha usa cubo limitado - Altera a representação do modelo para mostrar apenas um cubo com as dimensões do modelo. Mais veloz que a opção anterior.

Atualização automática durante mapeamento - Automaticamente atualiza o mapeamento quando o mesmo é alterado.

Exibir mapeamento rápido - Aumenta a velocidade da renderização se Usar mapeamento de imagens estiver ativo.

Mapa em grampo - Exibe o mapa em grampo.

Iluminação de profundidade - Aumenta a saturação da iluminação.

Neblina - Renderiza com neblina.

Definir cor do fundo - Altera a cor do fundo da vista câmera OpenGL.


Wireframe Camera View

Vista câmera em malha

A vista câmera sem renderização OpenGL apresenta o objeto em malha.

para exibir a vista Câmera pressione F11 ou o botão direito do mouse na vista OpenGL executando a operação Ocultar vista OpenGL.


Hidden Line Camera View

Não exibir Linha oculta

Exibe a vista câmera sem as linhas ocultas, essas linhas são as arestas que estão atrás das faces que estão voltadas para o observador.

Botão direito para não exibir as linhas ocultas.

Linhas ocultas não exibidas

Linhas ocultas exibidas

Para alternar para a vista OpenGL sombreada pressione F11, ou o botão direito na vista e acessando a opção exibir vista sombreada via OpenGL.


Quick Render

Renderização rápida na vista câmera

Renderiza o conteúdo do Designer com mapeamentos, texturas, reflexões, etc. com anti-serrilhado médio. Ótimo pra previsualizar! F12 é o atalho do teclado para essa opção.

Dica: Renderização rápida é muito mais veloz se o monitor for definido para 16 milhões de cores.


Tools

Ferramentas

Clique na ferramenta para mais informações.


Object_Selector_Tool

Ferramenta selecionador de objetos

Seleciona vértices conectados clicando em um vértice apenas. Se ele estiver selecionado então será deselecionado.

Com essa ferramenta vc poderá selecionar um objeto complexo inteiro clicando em apenas um de seus vértices.

Clicando num vértice vc irá mover o Cursor3D para esse ponto.

Use o modificador Ctrl junto com o mouse para alternar entre seleção/deseleção. Usando o Ctrl permite vc colocar o Cursor3D em áreas onde vértices podem estar presentes sem alterar o status da seleção.


Vertex_Selector_Tool

Selecionador de vértices

Seleciona e move um vertice. Seleciona nós de um esqueleto e pivôs em volta do nó selecionado.

Clicando longe de um vértice e arrastando cria uma área de seleção. E essa área pode ser alterada conforme a lista abaixo.

Modificador | Ação resultante
Nenhum | Seleção retangular
Alt | Deseleção retangular
Shift | Seleção laço
Shift + Alt | Deseleção laço
Ctrl | Seleção circular
Ctrl + Alt | Deseleção circular


Selection Marquee Tool

Ferramenta selecionador

Arraste o retângulo envolvendo os vértices para selecionar ou deselecionar.

  • Usando junto com a tecla Shift enquanto arrasta altera o selecionador para Laço selecionador.

  • Usando junto com a tecla Ctrl enquanto arrasta altera o selecionador para um selecionador em círculo.

  • Duplo clique na ferramenta altera para deselecionador.


Hand_Tool

Ferramenta Panorâmica

Move a vista pelo espaço. Duplo clique centraliza a vista no Curso3D.


Zoom_Tool

Ferramenta Zoom

Amplia ou reduz a vista.

Clique e arraste para definir a região que será ampliada ou reduzida.

Um duplo clique na ferramenta exibe todos os objetos nas vistas.


Move_Tool

Ferramenta mover

Esta ferramenta move os Vértices para uma nova localização.

Clique em qualquer lugar na vista e arraste. um retângulo púrpura aparecerá, mova para a posição desejada e solte

Para mover a uma posição específica, dê um duplo clique na ferramenta a caixa de diálogo Mover Vértices irá aparecer.


Rotate_Tool

Ferramenta rotacionar

Rotaciona os vértices selecionados em volta da posição do Cursor3D na vista ativa.

Clique sem mover o mouse para colocar o Cursor3D na coordenada que será o centro da rotação. Clique na janela e arraste o mouse para esquerda ou direita para interativamente rotacionar os vértices selecionados em volta do Cursor3D.

O eixo da rotação é definido pela vista ativa. Para rotacionar num ângulo específico, dê um duplo clique na ferramenta rotacionar e acesse a Caixa de Rotação.

Para rotacionar 1 grau de cada vez, use as teclas de seta. Para rotacionar 5 graus de cada vez, use SHIFT junto com as teclas de seta.


Scale_Tool

Ferramenta escala

Escalona os vértices selecionados sobre a posição do Cursor3D.

Fatores de escala como eixos podem ser ajustados com as teclas de modificação.

Clique sem mover o mouse para colocar o Cursor3D nas coordenadas desejadas do centro do escalonamento. Clique esquerdo em uma vista e arraste o mouse para a direita ou para a esquerda para iniciar o escalonamento dos vértices selecionados.

As teclas modificadoras são

Shift | Expande na direção Y Anterior/Posterior
Ctrl | Expande na direção Z Superior/Inferior
Alt | Expande na direção X Esquerda/Direita

Se deseja escalonar precisamente, use dê um duplo-clique na ferramenta e a caixa de diálogo Escala aparecerá.


Pen Tool

Ferramenta Caneta

Esta ferramenta cria uma curva (composta por um conjunto de vértices e arestas) nas vistas.

Coloque o primeiro vértice da curva clicando em algum lugar da vista. Clique e arraste o Cursor3D para a posição desejada do próximo vértice da curva. Solte o Botão esquerdo do mouse para inserir o novo vértice. Repita a operação para os outros vértices.

Se a tecla "Shift" estiver pressionada enquanto arrasta a linha será travada em ângulos de 45 graus.

Se a tecla "Ctrl" estiver pressionada enquanto arrasta nenhum novo vértice será criada. Serve para posicionar o Cursor3D nas vistas.

Se a tecla "Alt" estiver pressionada enquanto arrasta uma Nova aresta será iniciada. A nova aresta não será ligada ao vértice criado anteriormente.

A Ferramenta Caneta pode tambérm ser usada para desenhar arestas a partir de vértices já existente bastando clicar sobre o vértice para iniciar a aresta, podendo também clicar sobre um vértice existente para fechar a aresta.

Duplo clique na ferramenta ativa a Ferramenta Lápis.

Veja também:
Criação de Face e aresta
Facetando


Magnet Tool

Ferramenta Deformador Imã

Essa ferramenta na verdade são 4 em um e move os vértices selecionados de acordo com a escolha da ferramenta e da posição do Cursor3D.

Experimente usar os modificadores Alt, Ctrl, Shift.

Para ativar a Ferramenta deformador secundária, dê um duplo-clique na ferramenta.


Add Object

Adicionar Objeto

Adicionar Objeto insere formas primitivas: Cone, Cubo, Cilindro, Disco, Polígono, Retangulo, Esfera, e Tubo na área 3D na posição do Cursor 3D. Texto 3D pode ser inserido usando fontes TTF ou Postscript.

Escolha a primitiva desejada pelo painel flutuante.

Primitivas podem ser geradas com características específicas usando o menu Criar> Criar primitivas menu.


Cube Primitive

Primitiva Cubo

O Adicionar objetos > Cubo insere uma primitiva cubo na localização do Cursor3D.

Cubos podem ser gerados com dimensões exatas ou desenhadas interativamente usando Criar> Criar primitivas.

Digite as desejadas largura, comprimento, altura e ponto central, então pressione o botão criar. Note que o centro é o lugar especificado no espaço 3D onde ele será criado.


Sphere Primitive

Primitiva geo-esfera

Adicionar objeto insere uma esfera geodésica na vista na localização do Cursor3D.
Uma esfera geodésica possui propriedades que a tornam simétrica em qualquer posição do observador.

Elas podem ser geradas com dimensões exatas ou desenhas interativamente usando o menu Criar > Criar primitivas.

Insira os desejados valores para o raio, número de faces, suavização (desligada cria esfera facetada) ponto central, então pressione Criar. Note que o ponto central é o lugar na área 3D onde o ponto central da esfera vai ser colocado.


Sphere Primitive

Primitiva esfera

Uma esfera é modelada com linhas de latitude e longitude como as usadas para mapear a superfície da terra.

Primitivas esferas podem ser geradas com dimensões exatas ou desenhadas interativamente usando o menu Criar > Criar primitivas .

Elas podem ser geradas com dimensões exatas ou desenhas interativamente usando o menu Criar > Criar primitivas.

Insira os desejados valores para o raio, número de faces, suavização (desligada cria esfera facetada) ponto central, então pressione Criar. Note que o ponto central é o lugar na área 3D onde o ponto central da esfera vai ser colocado.


Rectangle Primitive

Primitiva Retângulo

Adiciona um retângulo na posição do Cursor3d.

Eles podem ser gerados com dimensões exatas ou desenhados interativamente usando o menu Criar> Crira primitivas.

Na caixa de diálogo atribua os valores para largura, comprimento, ponto central, e pressione o botão Criar. Note que o ponto central é o ponto no espaço 3D que onde o centro do modelo é colocado.


Cylinder Primitive

Primitiva cilindro

O adicionar cilindro insere um cilindro na localização do Cursor3D.

Clilindros podem ser criados com dimensões exatas ou desenhados interativamente usando o menu Criar > Criar Primitivas.

Escreva as desejadas altura, raio, número de lados, então pressione Criar.


Cone Primitive

Primitiva Cone

Adicionar objeto cone insere um cone na localização do Cursor3D.

Cones podem ser gerados com dimensões exatas ou desenhados interativamente usando o menu Criar > Criar primitivas.

Escreva o desejado raio, altura, número de lados, ponto central, então pressione Criar. Note que o ponto central é o lugar na área 3D onde o ponto central do cone vai ser colocado.


Polygon Primitive

Primitiva Polígono

Adiciona um polígono na vista na posição do Cursor3D.

Eles podem ser gerados com dimensões exatas ou desenhados interativamente usando o menu Criar> Crira primitivas.

Na caixa de diálogo atribua os valores para Raio, número de lados, ponto central, e pressione o botão Criar. Note que o ponto central é o ponto no espaço 3D que onde o centro do modelo é colocado.


Tube Primitive

Primitiva Tubo

Adicionar objeto insere um tubo na vista na localização do Cursor3D.

Eles podem ser gerados com dimensões exatas ou desenhados interativamente usando o menu Criar > Criar primitivas.

Insira os desejados valores para o raio, altura, lados, passos, ponto central, então pressione Criar. Note que o ponto central é o lugar na área 3D onde o ponto central do tubo vai ser colocado.


Add TrueType Text

Adiciona Texto TrueType

Adiciona um texto com projeção 3D usando fonte TTF.

Escolha a fonte desejada na caixa de diálogo da fonte.

A fonte escolhida é carregada no Utilitário de Criação de texto.

Escreva o texto na área específica, defina o tamanho da fonte, chanfro, cor, etc. Clique em criar quando estiver da forma desejada.


Add Postscript Text

Adicionar Texto Postscript

Adiciona um texto com projeção 3D usando fonte Postscript.

Escolha a fonte desejada na caixa de diálogo da fonte.

A fonte escolhida é carregada no Utilitário de Criação de texto.

Escreva o texto na área específica, defina o tamanho da fonte, chanfro, cor, etc. Clique em criar quando estiver da forma desejada.


Render Tool

Ferramenta renderizar

Clique na ferramenta e a caixa de diálogo aparecerá.


Render Control Tab Page

Renderizador OpenFX

Resolução - Escolha a resolução. Vc pode escolher de uma das pré-definições ou digitar o número de "pixels" para a imagem.

Anti-serrilhado - Escolha essa opção para definir o nível do anti-serrilhado. Basicamente anti-serrilhado suaviza o contornos dos objetos na renderização de forma a disfarçar os "pixels". Quanto maior o nível, maior o tempo de renderização.

Acelerar o Anti-serrilhado - Pode provocar resultados insatisfatórios. Experimente, se o resultado for bom para a imagem que vc está usando ele pode diminuir consideravelmente o tempo de renderização.

Misturar cores - Escolha o tipo de mistura que na verdade é otimização da paleta da imagem, imagens de 24 bit não precisam de mistura. Já imagens de 256 cores sim, essa é uma forma de evitar o "Banding" (cores num degradê quebradas por exemplo).

Há vários métodos de mistura. O "Floyd-Steinberg" é mais apropriado para imagens estáticas. "Noise Dithering" é mais apropriado para animação.

Formato da imagem - Selecione o formato. Isso irá determinar a paleta de cores automaticamente. GIF usa um formato de 8bits, TGA e TIF 16 bit ou 24 bit.

Tipo da animação - Selecione o formato.FLIC (256cores), AVI (padrão Windows), ou GIF animado (256cores). Note que arquivos FLC não possuem compressão se a resolução for maior que 640x480 "pixels".

Nome da imagem - Nome da imagem e pasta onde será gravada. Pasta padrão é "Render".

Nome da animação- Nome da animação e pasta onde será gravada. Pasta padrão é "Movies".

Quadro atual - Especifica qual quadro da animação será renderizado.

Alcance - Especifica um número de quadros que será renderizado.


Render Options Tab Page

Opções do Renderizador

Linha oculta - Renderiza a imagem desconsiderando as faces e arestas atrás dos modelos. Acelera a renderização.

Reflexo do solo com anti-serrilhado - Para reflexões do solo sem Raytrace.

Sem suavização - Desconsidera a suavização das faces e renderiza todos os cantos. Acelera a renderização e é possivel que ocorra desativação de algum mapeamento.

Reduzir Saturação - Pós-processo que remove cores 'ilegais' para o formato NTSC.

Escrever GIFs entrelaçado - Grava os GIFs no modo entrelaçado. O formato será o GIF 87.

Solo no canal alpha - Cria um alpha com o solo na imagem.

Escrever arquivo alpha separadamente - Escreve um arquivo alpha para cada imagem. Solo não está incluido.

Use armazenamento da tela cheia - Renderiza todos os "pixels" para um "buffer" de memória antes de cria o arquivo temporário. Ele aumenta a velocidade do Renderizador e imagens de Pós-processo requerem isso. Por outro lado exige um número alto de memória RAM.

Armazenamento Z - Cria um "buffer" com informação da profundidade da imagem. Use-o se a animação usa um pós-processo como neblina que requer essa opção ligada.

Usar armazenamento do ID do ator - Cria um "buffer" para o processo externo que identifica qual ator está visível na imagem final.

Exibir imagem enquanto renderiza


Render Settings Tab Page

Definições do renderizador

Velocidade da animação - Define a velocidae para arquivos FLI/FLC. O Valor é em unidade "jiffies", zero faz a animação rodar o mais rápido possível.

Ângulo da suavização

Luz ambiente % - Substitui a luz ambiente especificada no ator Atmosfera. Um máximo de 30% trabalha bem, valore maiores que 70% produz imagens com alto contraste.

Densidade da sombra % - Especifica a escuridão das sombras lançadas no solo. Define a densidade da sombra. 50% é o padrão, 100% produz sombras completamente negras, 0% não aparece sombra.

Armazenamento da Luz Spot - Altera a resolução das sombras lançadas pela luz. As sombras lançadas exigem memória. Um valor de zero impica que a luz não lança sombras. Vc pode calcular definições para resultados melhores multiplicando o número de "pixels" por 4 (isto é 320x200x4=256,000 bytes requiridos).

Ângulo da linha de ilustração -Ângulo máximo para as faces planas no modo Ilustração. Se duas faces são adjacentes e o angulo entre elas é menor que este valor o contorno não será desenhado. Um alto valor resultará em apenas um contorno no modelo na imagem, que pode ser útil para imitar o estilo "Cartoons" para desenho animado.

Valor do Ruído - Granula a imagem.

Desfoque de movimento - Valores altos geram desfoque de movimento. O alcance normal é 0-10. Quando um número fora desse alcance é definido a integração do desfoque inicia.

Dígitos nos nomes dos arquivos - Especifica o número do quadro no nome do arquivo renderizado.

Qualidade da imagem JPEG - Especifica a qualidade da compressão JPEG. Qualidade alta cria arquivos de grandes tamanhos.

Especificar números de processadores - Ativa seleção de 1-16 processadores ou coloca o renderizador automaticamente para determinar o número de processadores e atribuir a cada um trabalho.

Definições pessoais - Gravar e ler definições personalizadas.


Render Trace Tab Page

Raytrace

Opções para renderização utilizando Raytrace.

Traçar sombras - Todas as sombras são automaticamente calculadas.

Traçar reflexões - Todas as superfícies reflectivas autmoticamente são calculadas.

Traçar refração - Todas as superfícies com refração autmoticamente são calculadas.


Menus

Funções de todos os comandos do Designer.


File Menu

Menu Arquivo

Mostra as funções do menu arquivos.


File New

Arquivo novo

Inicia um novo modelo. Todos os dados serão apagados e a área de trabalho do OFX será limpada.

O Centro do modelo e o ponto perseguidor por padrão serão centralizados na coordenada 0,0,0.


File Open...

Arquivo abrir...

Abre um arquivo MFX, DXF, ou 3DS.

.MFX | Formato nativo
.DXF | Formato padrão de programas CAD
.3DS | Formato 3D Studio Release 4


File Save

Arquivo gravar

Grava todo modelo atual aberto num arquivo MFX.

Se alguma modificação foi feita antes de fechar um aviso será mostrado.

Nota
Para gravar um modelo DXF, use Arquivo > Exportar Modelo > DXF .
Para gravar um modelo 3DS, use Arquivo > Exportar Modelo> 3DS .


File Save As...

Arquivo gravar como...

Grava o modelo atual com um nome específico.

O arquivo MFX atual se torna então o nomeado.

Nota
Para gravar um modelo DXF, use Arquivo > Exportar Modelo > DXF .
Para gravar um modelo 3DS, use Arquivo > Exportar Modelo> 3DS .


Export Model

Exportar Modelo

Exporta modelos como:

  • Objetos selecionados
  • Articulações Hierarquicas
  • Cartas
  • Caminhos
  • DXF
  • 3D Studio (.3DS)


Export Selected as Model

Exportar objetos selecionados

Grava somente vértices , arestas e faces selecionadas para um arquivo MFX.

Vérticnes em um modelo são atribuidos à articulação esqueleto . Se uma atribuição não for feita, eles serão aplicados à articulação principal.

Especifique o nome do arquivo e a pasta onde ele será gravado.


Export Hierarchy Joints as Model

Exportar ligações hierárquicas como modelo

Cria uma série de arquivos MFX baseados no esqueleto .

Esta função cria um arquivo MFX para cada Ligaçãoo do esqueleto e grava todos os vértices ligados a ela num arquivo com nome relacionado. A posição da ligação (x,y,z) é usada como o Centro do modelo para cada modelo no arquivo MFX. Arestas e faces ligadas aos vértices são gravados num arquivo MFX particular. Esse comando é muito parecido com Arquivo > Exportar Modelo > cartas .

Especifique a pasta para cada dado gravado. É interessante criar vários subdiretórios dentro do diretório do modelo principal para modelos complexos.


Export Letters as Model

Exporar letras como modelo

Grava um série de arquivos MFX criados pelo utilitário de criação de texto Postscript ou TrueType .

Esta função cria o arquivo MFX, namea por letra. O Ponto de influência é especificado no criador de textos, e ele definirá o Centro do modelo para cada letra. O Ponto perseguidor para cada letra é automaticamente definido para suportar apropriadamente o espaçamento proporcional entre os caracteres na animação.

especifique o diretório onde as letras serão gravadas. É interessante criar subdiretórios para cada fonte.


Export Model as Path

Exportar Caminho

Cria um arquivo de caminho (.PTH) a partir do caminho indicado.

Caminhos são usados pelo animador para fazer uma referência para um modelo ser animado, e no Designer para operações de extrusão.

Um caminho é indicado quando todos os vértices dele estão selecionados e o Cursor3D está sobre o primeiro vértice do caminho.

Especifique um nome de arquivo caminho (*.PTH) e o diretório. O diretório padrão é \models.


Export Model as DXF

Exporta o modelo como DXF

Exporta o modelo atual como uma arquivo DXF.

Arquivos DXF são usados basicamente em programas 3D CAD. Vértices ligados em cada articulação do esqueleto são gravados em uma camada diferente e entidades POLYFACE são criadas.

Especifique o diretório e o nome do arquivo.


Export Model as 3DS

Exportar modelo como 3DS

Exporta o modelo atual com um arquivo 3D Studio release 4 (3DS).

Especifique a pasta e o nome do arquivo.


VRML_HELP

Exportar modelo Realidade Virtual

Existem 2 elementos no exportador VRML, o exportador VRML do Designer que escreve os vértices e faces do modelo, e o exportador VRML do Animador que escreve um arquivo VRML colocando os modelos numa cena e adicionando plano de fundo, câmeras e caminhos.

Exportador VRML Designer

Use essa opção quando partes de um modelo estiver selecionada.

  • Indexação
  • Usar Prefixos
  • Digitos de Precisão
  • Criar Normais
Indexação

Faz o arquivo VRML ser editado ou lido num editor de textos com mais facilidade. Por outro lado cria uma arquivo maior.

Prefixo URL da imagem

Cada imagem é guardada com um caminho completo da pasta onde está.

Digitos de precisão

As coordenadas dos vértices são gravadas num formato de ponto flutuante, com esta opção vc pode escolher como serão usadas as unidades. Por exemplo, se 3 dígitos de precisão forem usados as coordenadas serão escritas no formato 4.533, 16.732 etc.

Normais

Um conjunto de normais podem ser gerados baseados nos ângulos das faces para cada vértice. Somente faces que possuem suavização são analizadas.

Notas importantes

Para criar representações VRML mais eficientes siga as convenções anotadas abaixo:

  • Uma forma VRML separada é criada para cada entrada na hierarquia do esqueleto. Sendo assim, um modelo complexo pode ser dividido em subunidades para cada nó (osso). Isto é essencial se um mapeamento é aplicado a qualquer face no modelo e ajudará na redução do tamanho do arquivo VRML.
  • Cada face atibuida a um nó no esqueleto é testada para verificar se existe um mapeamento aplicado. Visto ser somente possível usar um mapeamento para cada face.
  • Outro passo importante é ver se todos os mapeamentos são fixados, pois todos precisam ser desse tipo.
  • Reflexos, Refrações, relevos e texturas não são exportadas.

Exportador VRML do Animador

As opções adicionais são:

  • Vistas de acordo com a posição da câmera. Essa vista será acessada pelo browser.
  • Câmera com sensor de tempo. Posição e orientação são escritas para a câmera ativa no intervalo regular de quadros da animação.
  • Plano de fundo do ambiente usa seis imagens definadas nas URLs
  • Se atmosfera e solo estão incluidos na animação então eles serão representados no arquivo de saída do VRML.


Insert

Inserir

Insere uma das seguintes opções:

  • Modelo na Origem
  • Modelo no Cursor
  • Caminho


Insert Model at Origin

Inserir modelo na origem

Inseri um modelo na origem .


Insert Model at Cursor

Inserir modelo no cursor

Insere um modelo na localização do Cursor3D.

Os dados inseridos são combinados com os dados existentes no Designer. A posição de vértices adicionais são ajustadas.


Insert Path

Inserir caminho

Insere um caminho .

Selecione o arquivo (*.PTH). O diretório padrão para os caminhos é \models.


Render

Renderizar

Inicia a renderização sem passar peloConfiguração da renderização ou Ferramente renderizar.


Render_Setup

Render Setup...

Launches the Renderer.

Select the desired settings in the Control, Options, Settings, and Tracing tab pages of the Renderer dialog. Press the Render button at the bottom of the Renderer dialog to start rendering. Note that test renders be done quicker using the File > Quick Render (F12).

The renderer defaults to a Scanline Phong renderer. Various levels of Ray tracing can be enabled in the Tracing tab page. Phong rendering is suggested in most cases since ray tracing is notoriously memory and time intensive.

The renderer is multi-threaded and will benefit greatly if additional processors are installed in the system. Rendering on a two processor system will almost be twice as fast as with one processor.


Print

Imprimir

Seleciona uma imagem para imprimir.

É uma opção simples para rapidamente imprimir imagens renderizadas, screenshots, mapeamentos e outras imagens do projeto. Ele converte a imagem para preto e branco e usa a impressora padrão para imprimir.


Preferences

Preferência...

Especifica as preferências Gerais e de Inicialização do Designer.


Preferences General Tab Page

Preferences Gerais

Botões padrão - Coloca os nomes da vista na janela. Deve sempre estar ligado.

Visualização rápida - Em modelos complexos diminui a exibição de algumas arestas para acelerar a vista.

Desfazer ativo - Permite o uso do desfazer. Desabilitar essa função acelera as operações.

Exibir legendas nas ferramentas

Usar grandes vértices - Exibe vértices grandes nos modelos.

Usar a última colocação das janelas - Grava as posições da janela para que da próxima vez apareçam no mesmo lugar.

Usar pequenos ícones - Comprime o espaço dos ícones para aumentar o tamanho das vistas.

Paleta das ferramentas à esquerda - Se ticado, coloca as ferramentas à esquerda do monitor.

Renderiza cor do plano de fundo da vista OpenGL - Especifica a cor do fundo.


Preferences Startup Tab Page

Preferences de inicialização

Iniciar com vista OpenGL


Most Recently Used Files

Arquivos recentemente usados

Exibe o nome dos arquivos recentemente usados.

Selecione para abrir.


Exit Animator

Sair do Designer

Esta função fecha o módulo Designer e todo o trabalho nele.

Se alguma modificação no trabalho não foi gravada, uma caixa de diálogo será exibida para confirmar a gravação ou não antes de fechar o módulo.


Edit Menu

Menu editar

Funções especiais do Designer.


Undo

Desfazer

Desfaz a última operação realizada.

Lembre-se que não funciona com todas as funções, algumas não podem ser desfeitas.


Delete

Apagar

Apaga o item especificado na vista:

  • Vértices selecionados
  • Arestas selecionadas
  • Aresta indicada
  • Vértice indicado
  • Mapeamento de face
  • Hierarquia
  • Mapeamento de vértice
  • Todos


Delete Selected Vertices

Apagar vértice selecionados

Apaga os Vértices selecionados.


Delete Selected Edges

Apaga arestas selecionadas

Apaga as arestas selecionadas.

Somente as arestas selecionadas são apagadas enquanto os vértices selecionados em ambos as extremidades da arestas permanecem.a


Delete Indicated Edge

Apagar aresta indicada

Apaga a Aresta indicada.

Uma aresta está indicada quando o Cursor3d está diretamentes sobre a aresta especificada.


Delete Indicated Vertex

Apagar vértice indicado

Apaga vértice indicado .

Um vértice está indicado quando o Cursor3d está diretamentes sobre ele.


Delete Face Map

Apagar mapeamento de face

Apaga um mapeamento do modelo atual exibido:

Escolha o mapeamento a ser deletado da lista para esse modelo.


Delete Hierarchy

Apagar Hierarquia

Apagan nomes e Ligações na hierarquia do Esqueleto .


Delete Vertex Mapping

Apagar mapeamento de vértice

Apaga todos os mapeamentos de vértice dos vértices selecionados.


Delete All

Apagar Todos

Apaga o modelo inteiro.

Este comando não pode ser desfeito. Uma alternativa mais veloz é CTRL+N (Novo).


ZZZZ_INCOMPLETE

Help is not available on this topic yet.


Hierarchy Joints...

Ligações hierárquicas...

Criar, modificar ou usar para propósitos de seleção na caixa esqueleto da hierarquia.

Note: Esqueletos criados por esse caminho não possuem nenhuma relação geométrica particular com vértices, arestas e faces no modelo.

Seleciona vértices nomeados
Deseleciona vértices nomeados

Seleciona vértices nomeados incluindo suas "heranças"
Oculta vértice nomeados
Revela vértices nomeados ocultos
Anexa vértices selecionados ao nome
Desanexa vértices selecionados do nome
Adiciona nome
Apaga nome


Skeleton

Esqueleto

Possui vários comandos para manipular oesqueleto de um modelo.

  • Pôse
  • Criar ligação
  • Reposicionar ligação
  • Definir rotação da ligação
  • Remover ligação
  • Inserir ligação
  • Amarrar na ligação
  • Selecionar ligação
  • Aplicar mapeamento a ligação


Pose Skeleton

Pôse

Isto moverá os vértices no modelo que são amarrados a ligações. Movimenta os vértices pivôs amarrados a uma ligação indicada ao redor de qualquer um dos quatro eixos através das ligações indicadas ou seus parentes.

Quando este comando é executado, os vértices e arestas no modelo estão ocultos e o esqueleto é representado por caixas limitadas, uma para cada ligação. Cada caixa é orientadas a preencher na direção do eixo local determinado pelo comando Girar.

Skeleton as Vertices | Skeleton as Bounding Boxes

Para indicar uma ligação clique no pequeno círculo de cada nó da ligação. A cor do nó irá mudar e um eixo será iluminado, com um pequeno círculo no fim do eixo.

Selecione um eixo diferente pressionando a tecla TAB até o eixo desejado ser iluminado. Pode ser necessário rotacionar sobre mais eixos para obter a orientação desejado do osso.

Para rotacionar a ligação indicada e todos os filhos, clique e segure o botão esquerdo do mouse arrastando o mouse para esquerda ou direita.


Build Skeleton Joints

Criar ligações

Cria um esqueleto adicionando ligações. Os vértices e arestas do modelo permanecerão visíveis e qualquer esqueleto é desenhado sobreposto a eles. O nó raiz pode ser o único nó visível.

Adicionar uma ligação do esqueleto é similar a criar curvas com a ferramenta Lápis. Clique e arraste o Cursor3D próximo ao nó do fim da ligação para adicionar uma nova ligação. Pressione o botão esquerdo do mouse e clique com o direito para ligar na posição do Cursor3D. Clique e arraste para a posição do novo nó. Pressione o botão esquerdo e clique o direito para criar a nova ligação na posição do Cursor3D.


Reposition Skeleton Joints

Reposicionar as ligações

Altera a forma do esqueleto movendo as ligações .

Clique e arraste o Cursor3D próximo ao nó no fim da ligação a ser reposicionada. Pressione o botão esquerdo do mouse e clique o direito para 'pegar' o nó. Arraste o mouse mantendo o botão esquerdo pressionado, o nó seguirá o Cursor3D e a ligação será esticada. Se o CTRL estiver pressionado também, todos as ligações filhos irão acompanhar num movimento rígido.


Set Skeleton Joint Rotation

Definir rotação da ligação

Gira uma Ligação do esqueleto em volta de um eixo.

Clique e arraste o Cursor3D próximo ao nó no fim da ligação a ser girada. Pressione o botão esquerdo do mouse e clique o direito para selecionar o nó. Arraste o mouse mantendo o botão esquerdo pressionado para o local do pivô. Solte o botão quando o eixo estiver na posição desejada. A direções dos eixos locais são usados para criar a caixa limitada para os vértices amarrados a ligação.


Remove Skeleton Joint

Remover uma ligação

Remove uma ligação do esqueleto.

Clique e arraste o Cursor 3D para próximo do nó no fim da ligação a ser removida. Pressione o botão esquerdo do mouse e clique com o direito e a ligação será apagada. Qualquer ligação Filho continuará amarrada ao parente da ligação removida. O nó raiz não pode ser apagado.


Insert Skeleton Joint

Inserir Ligação

Adiciona uma ligação no meio de uma ligação existente.

Clique e arraste o Cursor3D próximo ao nó no final da ligação que será dividida. Pressione o botão esquerdo do mouse e clique o direito para subdividir o ligação.


Attach to Skeleton Joint

Amarrar na ligação

Atribui vértices a uma ligação do esqueleto.

Antes de usar esse comando, selecione os vértices que serão amarrados a nó. Clique e arraste o Cursor3D para próximo do nó no final de ligação onde os vértices serão amarrados. Pressione o botão do mouse e clique com o direito para amarrar. A Janela ficará inativa indicando que a operação foi um sucesso.

Nota: Vc achará mais fácil usar os nomes hierárquicos para atribuir vértices às ligações de esqueleto. Primeiramente desenhe o esqueleto e dê um nome a ele, então use a nomeclatura para atribuir.


Select Skeleton Joints

Selecionar ligações

Seleciona vértices amarrados a uma ligação do esqueleto.

Clique e arraste o Cursor3D próximo ao nó no fim da ligação para selecionar os vértices amarrados a ele. Pressione o botão esquerdo do mouse e clique o direito para fazer a seleção.

Usando a caixa de diálogo Hierarquia do esqueleto pode tornar mais eficiente a seleção de partes do esqueleto.


Apply Map to Skeleton Joint

Aplicar mapeamento a ligação

Atribui um mapeamento de imagem a uma das ligações do esqueleto.

Clique e arraste o Cursor3D próximo ao nó no fim da ligação para determinar onde o mapeamento será aplicado. Pressione o botão esquerdo do mouse e clique com o direito para aplicar. Abrirá um caixa de diálogo para vc determinar o arquivo e pasta do mapeamento.


Select Menu

Menu selecionar

Mostra as opções de seleção do Designer.


Select All

Selecionar tudo

Seleciona todos não-ocultos vértices no modelo.


Deselect All

Deselecionar Tudo

Deseleciona todos os vértices não ocultos no modelo.


Swap Selected

Inverter seleção

Todos os vértices selecionados se tornarão deselecionados e vice-versa.


Select Glue Mapped

Selecionar mapeamento fixado

Seleciona todos os não-ocultos vértices no modelo que possuem Mapeamento fixado aplicado.


Deselect Glue Mapped

Deselecionar mapeamento fixado

Deseleciona todos os vértices não ocultos no modelo que possuem mapeamento fixado aplicado neles.


Select by Map

Selecionar pelo mapeamento

Seleciona todos os vértices adjacentes a face com um mapeamento especificado.

Escolha uma das imagens do modelo. se uma imagem apenas for lida, a caixa de diálogo não aparecerá e as faces relacionadas serão selecionadas.


Select by Color

Selecionar pela cor

Seleciona todos os vértices adjacentes a face com a cor especificada.

A cor pode ser exata ou aproximada.


Select by Shader

Selecionar pela textura

Seleciona todos os vértices adjacentes a face com a textura especificada.


Deselect on Path

Deselecionar no caminho

Deseleciona n vértice (onde n = intervalo + 1) num caminho indicado e selecinado.

Se o valor do intervalo for 1, um vértice será selecionado e outro não sucessivamente. Um valor de intervalo de 2 selecionará o terceiro vértice e assim sucessivamente. E valores maiores seguirão a sequência.

Para que serve, veja esse exemplo: Vamos criar uma engrenagem.

1. Crie um círculo. Ele não deve possuir um vértice no centro.
2. Selecione o círculo e indique (cursor3d) um de seus vértices.
2. Escolha o comando Deselecionar no caminho e dê um valor de intervalo de 1.
3. Verifique se outros vértices foram deselecionados.
4. Dê um duplo-clique na ferramenta escala.
5. Selecione a opção "no centro" e altere o fator de escala.
6. Faça uma extrusão para criar a engrenagem.


Build Primitives

Criar primitivas

O Criar primitivas abre uma caixa de diálogo para geração de Cone, Cubo, Cilindro, Disco, Polígono, Retangulo, GEO Esfera,Esfera, Tubo e Toros com tamanhos específicos.

Escolha a primitiva desejada, coloque as dimensões, e pressione Criar. A caixa de diálogo permanecerá visível possibilitando criar outras geometrias até vc pressionar o botão fechar.

Vc pode gerar uma primitiva arrastando a ficha da primitiva para uma vista e arrastando novamente na vista um retângulo que representará o tamanho da forma a ser criada. A opção Auto deve estar ligada para funcionar.


Build Bezier Curves

Criar Curvas Bezier

Ativa a construção de curvas Bezier 2D que podem ser inseridas nas aréas de trabalho do Designer, utilizando a ferramenta "Bezier Curve Drawing".

Desenha e manipular a curva bezier desejada usando as ferramentas abaixo:

Move o vértice indicado da curva bezier
Move a curva bezier indicada
Desenha curvas bezier. Clique em outra ferramenta para finalizar a curva.
Dobra curvas bezier
Apaga um vértice indicado na curva bezier
Apaga uma curva bezier indicada
Adiciona vértices na curva bezier.

Para inserir a curva bezier criada na área de trabalho do Designer, execute o comando Editar > Criar no menu.

Note que é possivel criar várias curvas e gravá-las. Isso é muito útil para criar seções curvas para serem extrudidas na criação de um modelo.


Build Curve

Cria curvas através de coordenadas exatas definidas na caixa de diálogo.

Entre as coordenadas absolutas ou relativas para o início da curva.

1) Escreva a coordenada desejada e pressione iniciar.

2) Escreva a segunda série de coordenadas para o segundo vértice da curva. Pressione Criar

3) Continue Escrevendo as coordenadas para os outros vértices. Pressione Criar para cada um, relativo é em relação ao vértice anterior

4) Pressioen Fechar para finalizar a curva.


Build from Plan

Criar a partir de um Plano

Monta um objeto a partir de um grupo de planos ou elavações.

Como exemplo, cria um telefone de um conjunto de planos usando o arquivo Plan1.MFX.

Execute o comando Arquivo->Abrir e escolha o arquivo Plan1.MFX. Note que o modelo consiste de 3 contornos de um telefone. A única diferença entre este e um conjunto regular de planos é que cada desenho está posicionado no espaço tridimensional.

Siga esses passos para cria o modelo a partir dos planos:

  • A elevação lateral precisa estar deselecionada.
  • Os outros contornos precisam estar selecionados.
  • O cursor3D precisa ser colocado exatamente em um vértice do contorno da projeção frontal. Se o contorno não for fechado, coloque o cursor em um dos vértices finais. Coloque o Cursor 3D próximo do vértice desejado, pressione F2 para travar no vértice desejado.
  • A elevação lateral precisa ser uma curva fechada sem cruzamento de arestas

Deselecione os vértices da elevação lateral, e execute Criar > Criar a partir de um plano no menu. Se todos os critérios foram seguidos, uma caixa de diálogo ser apresentada, se ela não aparecer quer dizer que o conteúdo não está satisfazendo as regras. Verifique de novo as condições.

Clique no botão Sim para construir o objeto. Após, os três planos serão mantidos e todos os vértices deselecionados.

O resultado final se parecerá com isso:

Se as teclas Shift, Ctrl ou Alt forem pressionadas quando o Sim for clicado o nível de detalhamento do modelo será grande. Alt = alto detalhe.


Make Facet or Edge

Criar face ou aresta

Cria uma aresta entre dois vértices selecionados.

Cria uma Face entre 3 vértices selecionados. Uma, duas ou três arestas serão criadas dependendo do número de arestas originalmente conectadas nos vértices selecionados. Toda nova face criada tem a textura padrão aplicada.

Se mais que 3 vértices estão selecionados, nenhuma aresta ou face será criada.


Make Vertex at Cursor

Criar vértice no cursor

Cria um Vértice selecionado na posição do Cursor3D .


Build 3D Meshes

Criar Malha 3D

Cria uma malha 3D a partir de uma função matemática z=f(x,y)

Escolha a função matemática e especifique o tamanho da grade para X,Y. O Z será proporcional.


Build Circle

Criar Círculo

Cria um círculo com o número especificado de lados na caixa de diálogo.

O círculo é inserido com seu centro determinado pela posição do Cursor3d.


Build Helix

Criar Hélice

Cria uma Hélice (tipo saca-rolha) com número de vértices especificados na caixa de diálogo.

A hélice é inserida com seu centro na posição do Cursor3D.


Build Subdivided Line

Criar linha subdividida

Cria uma linha com espaçamento variável entre os vértices.

Os espaços entre os vértices são resultantes de uma fórmula matemática. Especifique o número dos vértices e o raio do espaçamento entre vértices adjacentes

A linha é inserida com seu centro na posição do Cursor3d.


Build Spiral

Criar Espiral

Cria um caminho em espiral

Especifica o tipo da espiral, número de pontos e alcance da curva. Uma espiral Arquimediana é para dentro. Uma espiral logarítimica é para fora.

A espiral é inserida com seu centro definido pela posição do Cursor3D.


Build 3D Spiral

Criar Espiral 3D

Cria um caminho espiral 3D

Especifica o tipo da espiral, número de pontos e alcance da curva. Uma espiral Arquimediana é para dentro. Uma espiral logarítimica é para fora.

A espiral é inserida com seu centro definido pela posição do Cursor3D.


Build Terrain From Bitmap

Criar Terreno a partir de um Bitmap

Criar uma superfície 3D de um arquivo imagem.

Escolher o arquivo imagem desejado.

Definir a densidade da malha em baixa, média ou alta.

O número de linhas define a desidade x e o número de colunas define a y.

O Z (Altura) da malha é proporcional a cor ou luminosidade da imagem.

O Terreno é inserido com seu centro na posição do Cursor3D.


Trace Bitmap Image

Vetorizar imagem

Use uma imagem com referência para traçar uma curva.


Build Custom Bounding Box

Customizar Cubo Limitado

Use essa opção para dar ao modelo a aparência de um simples cubo para representar o objeto no Animador. O objetivo é economizar memória de vídeo numa cena complexa.

Criar - Todos os vértices e arestas selecionadas serão representadas por um cubo no Animador. O limite é de no máximo 50 vértices e arestas

Auto Criar - Cria automáticamente do objeto selecionado.

Desfazer criação - Se um cubo limitado já existir, ele é convertido em vértices e arestas mas mantendo a informação do cubo limitado.

Limpar - Se um cubo limitado já existir, ele é convertido em vértices e arestas e a informação do cubo será apagada.


Plug-in Modeling Tools

Extensões de modelagem

Exibe extensões adicionais feitas por terceiros. Algumas podem estar em inglês ou outra lingua se forem programados assim, pois tratam-se de programas externos e alguns podem ser freeware shareware ou comprados.

Elas estão na pasta "plugins" do Designer.


Actions Menu

Menu Ações

Funções especiais do Designer.


Rotate Action

Ação rotacionar

Rotaciona vértices selecionados em volta da posição do Cursor3D Via um ângulo numérico.

Determine se a rotação será em sentido-horário ou anti-horário em relação ao Cursor3D na vista ativa.


Scale Action

Ação escala

Escalona vértices ou faces pelo fator numérico.

A expansão pode ser opcionalmente atribuída ao eixo Z (Superior/Inferior), Y (Anterior/Posterior) e X (Esquerda/Direita)

Vértices - Escalona os vértices selecionados a partir da posição do cursor3D ou do centro dos vértices selecionados. Esta é a opção mais comumente usada.

Faces - Escalona as faces selecionadas sem afetar o tamanho do modelo por inteiro.

A partir do cursor - Escalona os vértices ou faces selecionados realativamente a posição do Cursor3D.

A partir do centro - Escalona os vértices ou faces selecionados para o centro dos mesmos.


Snap Cursor

Travar Cursor

Move o Cursor3D para uma posição específicada por uma das regras das opções.


Snap Cursor to Center

Travar cursor no centro

Move o Cursor3D para o Ponto pivô do modelo.

O Ponto pivô de um grupo de vértices é o ponto médio tridimensional de um imaginário cubo envolvendo os vértices, assumindo que o cubo está alinhado com os eixos das coordenadas.


Snap Cursor to Center Selected

Travar cursor no ponto pivô do selecionado

Move o Cursor3D para o Ponto pivô dos vértices selecionados do modelo.

O Ponto pivô de um grupo de vértices é o ponto médio tridimensional de um imaginário cubo envolvendo os vértices, assumindo que o cubo está alinhado com os eixos das coordenadas.


Snap Cursor to Centroid

Travar cursor no centro de massa

Move o Cursor3D para o Centro de massa do modelo.

O centro de massa de um grupo de vértices é o centro de gravidade ou a média das posições individuais de vértices.


Snap Cursor to Closest

Travar cursor fechado

Move o Cursor3D para o vértice não oculto mais fechado.

Coloque o Cursor3D o mais fechado possível próximo ao vértice na vista para travar o cursor nele.


Snap Cursor to Closest Selected

Travar cursor fechado selecionado

Move o Cursor3D para o vértice selecionado não oculto mais fechado.

Coloque o Cursor3D o mais fechado possível próximo ao vértice na vista para travar o cursor nele.


Snap Cursor to Horizontal Plane

Travar cursor no plano horizontal

Move o Cursor3D para o ponto pivô dos vértices no plano XY, mantendo a coordenada Z do Cursor3D constante.


Move Cursor by...

Move para...

Move o Cursor3D para a posição indicada na caixa de diálogo.


Store Cursor Location

Guardar localização do Cursor

Guarda a localização atual do Cursor3D.


Snap Cursor to Stored Value

Travar cursor no valor guardado

Move o Cursor3D para o valor quardado.


Snap Cursor to Coordinate

Travar cursor na coordenada

Mover o Cursor3D para a coordenada especificada.


Snap Cursor to Vertical Plane (F/B)

Travar o cursor no plano vertical (Anterior/Posterior)

Move o Cursor3D para o Ponto pivô dos vértices no plano XY, mantendo a coordenada X do Cursor3D constante.


Snap Cursor to Vertical Plane (R/L)

Travar o cursor no plano vertical (Direita/Esquerda)

Move o Cursor3D para o Ponto pivô dos vértices no plano XY, mantendo a coordenada Y do Cursor3D constante.


Extrude

Extrusão

Extrude vértices e arestas selecionados para criar uma forma 3D.

Antes de executar a ação, a ferramenta reverte para Mover. Arraste os selecionados para a dimensão desejada da extrusão.

Note que vc pode fazer reentrâncias ou saliencias no modelo extrudindo e escalonando para o tamanho desejado.

Para extrudir vértices selecionados seguindo um caminho definido, use Ações > Extrusão especial > no caminho.


Extrude Special

Extrusão especial

Extrude vértices e arestas usando técnicas especiais para criar uma forma 3D.


Extrude Along...

Extrusão no caminho...

Extrude vértices e arestas seguindo um caminho para criar uma forma 3D.

O seguinte exemplo criará um tubo.

1) Adicione um Circulo.
2) Desenhe uma linha curva como demonstrada no exemplo abaixo.
3) Deselecione todos os vértices. Selecione os vértices da seção que será extrudida.
4) Mova o Cursor3D para o primeiro vértice do caminho. Com a ferramenta selecionador, clique no primeiro vértice para selecionar todos os vértices do caminho.

5) Execute Extrude-> no caminho... no menu, e se se o programa decidir que está tudo OK, uma caixa de diálodo aparecerá para confirmação final da operação.

6) Pressione o botão OK usando o fator de expansão 1.0000.
7) O círculo será extrudido no caminho acompanhando a curva como mostrado abaixo.

A função extrusão pode ser escalonada durante a projeção. Clique em Expandir na confirmação, então entre o fator de expansão. Ele ocorrerá do primeiro ao último ponto do caminho.

# Mapeamento de imagem - Se mapeamento fixado está atribuido aos vértices no início da extrusão, a ação extrudirá as coordenadas de acordo com a curva. O número de vezes que o mapa é repetido na extrusão é colocado na caixa de diálogo.


Extrude Bevel...

Extrusão chanfro...

Extrude os vértices selecionados com um chanfro.

Esta ação coloca um chanfro em um curva fechada. O ângulo do chanfro precisa ser especificado e a curva precisar ser plana.

Coloque o Cursor3D na direção e na distância desejada para o chanfro.

Curvas falsas dentro de outras curvas são consideradas buracos, e elas serão chanfradas no ângulo oposto da curva externa. Os vértices selecionados precisam formar um conjunto de curvas fechadas.


Extrude Round Over...

Extrusão ao redor...

Extrude os vértices selecionados num chanfro arredondado.

Esta ação é muito similar a Extrusão em chanfro exceto que um um chanfro arredondado é criado no conjunto de curvas. A extrusão vai da curva até a posição do Cursor3D.


Duplicate

Duplicata

Cria cópias de todos os vértices, arestas, e faces selecionadas.

A cópia é independente do original. É um novo objeto.


Duplicate Special

Duplicata especial

Cria copias dos vértices, arestas, e faces selecionadas como cópias connectadas ou cópias múltiplas especificadas.


Duplicate Connected

Duplicata conectada

Cria uma duplicata dos vértices selecionados e os definem como malha conectada.

Vc pode usar essa ação para aumentar o número de pequenos detalhes no modelo.


Duplicate Multi...

Duplicata Multi...

Copia os vértices selecionados em uma simetria rotacional colocando o número de cópias definidas previamente.

Essa ação é igual a Ação Tornear, porém é criada uma cópia em cada seção.


Boolean Action

Operação Booleana

Usa uma ou mais formas como ferramentas para cortar ou transformar em outras formas.

Esculpir objetos com outro modelo para alterar drasticamente a forma. O exemplo abaixo usa uma esfera com textura em xadrez como ferramenta de corte no cubo vermelho. Depois de efetuar a operação Booleana, as peças de corte podem ser removidas em várias combinações para criar novos modelos.

União | Subtração | Interseção

Para executar uma operação Booleana, siga os passos:

1) Interseccionar a esfera e o cubo como mostrado na figura União (Não se preocupe com as texturas agora).

2) Selecione os vértices da esfera para indicá-la como a ferramenta de corte. Deixe os vértices do cubo deselecionados para indicá-lo como a Peça de trabalho.

3) Execute a Ação Booleana e siga a caixa de diálogo que aparecerá.

4) Escolha as opções Sim e Ambos então pressione OK.

5) Apague os vértices dos fragmentos desejados para esculpir a nova forma com apresentado nas figuras por União, Subtração, eInterseção.

6) Para fazer um simples objeto fora das peças separadas, selecione todos os vértices e execute o comando Soldar com um pequeno valor de percentual.

Peça de Trabalho - É o objeto que será cortado pelo objeto de corte. Os vértices deselecionados definem a peça de trabalho.

Quebrar em partes - Separa a ferramenta corte e a peça de trabalho se o Sim estiver ticado.

Cortar - Opção Ambos corta a ferramenta corte (vértices selecionadas) e a peça de trabalho (vértices selecionados). A opção Peça de trabalho corta somente a peça de trabalho.

Se qualquer peça cortada formar um loop fechado, os fragmentos serão separados e ganharão um nome na Hierarquia do Esqueleto. Note que a função booleana pode criar vértices e arestas que não formam faces. Apague elas da cena.

Não oculte nenhum vértice que faça parte da peça corte ou da peça de trabalho. Ocultar outros vértices na cena pode acelerar o processo booleano.


Fill to Cursor

Preencher no cursor

Cria faces para preencher o espaço envolvido por vértices selecionados. Um vértice extra é colocado na posição do Cursor3D . O vértice extra é unido aos outros vértices por arestas. Onde os vértices formares faces, elas serão adicionadas.

Esta função é muito útil para preencher contornos convexos.

Contorno vazio

Preencher no cursor com o Cursor3D no mesmo plano do contorno

Preencher no cursor com o Cursor3D acima do plano do contorno.


Fill Outline

Preencher contorno

Preenche curvas fechada simples ou múltiplas com arestas e faces para torná-las sólidas e portanto visíveis na renderização.

As curvas precisam estar num mesmo plano e não intersecionar-se. Se uma curva estiver dentro de outra isso poderá resultar num buraco na curva interna (como um buraco num letra).

Contorno vazio

Contorno preenchido


Lathe

Tornear

Cria rotacionalmente uma forma simétrica.

A ação extrude os vértices selecionados rotacionando-os sobre um eixo. Dois parâmetros devem ser especificados na caixa de diálogo:

1) O número de seções (para suavizar o torneado)
2) O ângulo do giro (normalmente 360 graus, máximo de uma revolução)

Exemplo: Use a ação tornear para criar uma taça. Na vista Anterior, desenho o meio contorno da taça.

Quando vc estiver satisfeito como o contorno, posicione o Cursor3D na vista superior. A vista superior agora será ativa e será iluminada com um contorno amarelo. O eixo do giro de um torneado é definido pela posição do cursor3D. A ação fará o torneado sempre com referência a vista ativa.

Verifique se todos os vértices do contorno estão selecionadas, então efetue a ação. Se vc não gostou do resultado imediatamente execute a opção Desfazer (Ctrl Z) e experimente novamente.

A ação Tornear é extremamente poderosa para construir uma infinidade de partes de um modelo como por exemplo: Peças de Xadrez, Propulsores de aeronaves, canetas, copos, lâmpadas, foquetes, torres de castelos, etc.


Loft Curves

Projetar 2 Curvas

Une duas Curvas fechadas e separadas para criar uma superfície.

Os vértices precisam estar selecionados. As curvas não podem possuir interseções (como um 8). Elas podem ter diferentes números de vértices, mas o programa ajustará a diferença da melhor forma que ele calcular.

Before Lofting

After Lofting

Para projetar mais de uma curva, use a ação Prejetar múltiplas curvas.


Join Closed Curves

Projetar múltiplas curvas

Une duas ou mais Curvas fechadas separada para criar uma superfície.

Os vértices precisam estar selecionados. As curvas não podem possuir interseções (como um 8). Elas podem ter diferentes números de vértices, mas o programa ajustará a diferença da melhor forma que ele calcular.

Antes de unir as curvas

Depois de unir as curvas


Mirror...

Espelhar...

Todos os vértices selecionados são movidos para a posição da imagem espelho.

O plano do espelho atravessa o cursor3D pelo ângulo direito da janela ativa.

Sobre a linha vertical - Espelha os vértices selecionados através de uma linha imaginária vertical na posição do Cursor3D em relação a vista ativa.

Sobre a linha horizontal - Espelha os vértices selecionados através de uma linha imaginária horizontal na posição do Cursor3D em relação a vista ativa.

Copiar, Refletir, e soldar - Cria a copia espelhada, e então solda os vértices indicados. Se os vértices não estiverem indicados a ação não ocorrerá.


Orient Faces

Orientar Faces

Altera a ordem dos vértices em cada canto de uma face para que as faces adjacentes possuam a mesma orientação (Sentido horário ou anti-horário).

Prática com a ação Inverter Normal das Faces para exportar modelos para outros pacotes 3D.


Reverse Face Normals

Inverter normais da face

Inverte a normal da face associada com os vértices selecionados. A normal é o lado da face que é visível, o outro lado é invisível.

Usual com a ação Orientar Faces para limpar modelos importados que não suportam Faces de duplanormal.

Desligue na Vista OpenGL poligonos com dupla-normal para ver as normais da face.


Smooth

Suavizar

Suaviza um Caminho ou curva .

Selecione os vértices no caminho. Coloque o Cursor3D no primeiro vértice no caminho, então execute a operação. A primeira e a última aresta controla o início e o final da curva. Os vértices remanescentes ao longo do caminho serão movidos para suavizar a curva conforme os controladores.

Modificadores-> Modifica a força da suavização. CTRL exibe uma caixa de diálogo chamada Flexibilidade.


Subdivide

Subdividir

Divide aresta selecionadas em duas adicionado um vértice no ponto médio dela.

Se a divisão possibilitar formar faces , elas serão adicionadas.

Antes da subdivisão

Após subdivisão

Contraste essa operação com a ação Tesselate .


Twist Along

Girar no caminho

Girar executando uma extrusão nos vértices e arestas selecionados num caminho para criar formas tipo sacarolha.

Prático para criar modelos como um cabo de telefone. Modelos inteiro podem ser copiados e girados no caminho.

1) Adiciona um Circulo.
2) Desenhe uma curva com a demonstrada abaixo.
3) Deselecione todos os vértices. Selecione a seção a ser girada.
4) Mova o cursor3D para o primeiro vértice do caminho. Com o selecionador de objetos, clique no primeiro vértice do caminho para selecionar todos os vértices nele.

5) Execute o intem no menu Girar > no caminho, e se o programa achar válida a operação, uma caixa de diálogo será mostrada.

6) Pressione o botão OK usando o número de passos padrão e o ângulo do giro.
7) O círculo será extrudido na curva como a figura abaixo mostra.

Número de passos - Especifica o número de giros que as cópias da seção farão no caminho. Ex: Se o caminho possuir 10 vértices e os passos forem 8, um total de 80 cópias serão criadas, 8 para cada intervalo entre vértices no caminho.

Ângulo do giro- Especifica o ângulo que as cópias irão rotacionar (usualmente 360 graus, o máximo de uma revolução)

Extrusão - Extrude a forma original.

Copiar - Cria cópias da forma no caminho.

# Mapeamento -Se fixado estive aplicado todas os vértices extrudidos receberão as coordenadas. O número de vezes do mapeamento é repetido durante a extrusão.


Weld

Soldar

Solda os Vértices selecionados em um.

Pelo Cursor - Condensa os vértices selecionados para a posição do Cursor3D.

VC pode usar essa operação por exemplo, para fechar buracos nos modelos.

No centro de massa - Condensa os vértices num único na localização do centro de massa do objeto.

Soldar: Soldagem simples de acordo com o raio na caixa de diálogo. O Raio padrão que aparece é a distância do Cursor3D até o vértice selecionado mais próximo dele.


Separate Polygons

Separar polígonos

Quebra faces selecionadas em peças individuais.

Após a operação cada face será um objeto separado, os vértices que eram únicos em faces adjacentes serão dividos formando um para cada face na mesma coordenada, a aparência geral do modelo será a mesma.

Essa operação é para ser usada por exemplo antes de animar um modelo explodindo com a ação Explodir Polígonos.

Note que suavização não é aplicável porque as faces são agora entidades separadas.


Explode Polygons

Explodir Polígonos

Explode os polígonos de acordo com regras específicas.

Escolha a partir das opções seguintes:

Explodir as faces a partir do centro do modelo - a partir do ponto central.

Centro da esfera no Cursor3D - Explode os polígonos em forma de esfera.

Plano horizontal no Cursor3D - Achata os polígonos selecionados a altura zero (na dimensão Z) e coloca na posição do Cursor3D.

Plano Vertical (Anterior/Posterior) no Cursor3D - Achata os polígonos selecionados no comprimento zero (na dimensão X) e coloca na posição do Cursor3D.

Plano Vertical (Esquerda/Direita) no Cursor3D - Achata os polígonos selecionados na largura zero (na dimensão Y) e coloca na posição do Cursor3D.

Mover vértices para próximo dos pontos da grade - Explode os polígonos fazendo com que os vértices de cada polígono sejam movidos próximo ao ponto da grade ativo mais próximo.

Opções da explosão das faces

Aleatório | Explode aleatoriamente usando especificados fatores. Recomendado para explodir veículos, naves espaciais,etc.
Proporção | Explode proporcionalmente ao tamanho do polígono.
Uniforme | Explode unifomemente.

Fator de explosão - Indica de onde mais polígonos serão explodidos. Nenhum valor negativo deve ser atribuido.


Attributes Menu

Menu Atributos

Descreve as funções dos comandos de atributos do Designer.


Attributes Material Settings

Definir atributos para faces...

Define cor, superfície, textura, mapeamento e suavização.

Os atributos aplicados às faces no modelo ditam a aparência do modelo quando for renderizado. O realismo e qualidade da imagem produzida é altamente influenciado por esses atributos que vc pode alterar na caixa de diálogo.

Atributos são aplicados às faces selecionadas. Uma face é selecionada se todos os vértices dos seus cantos forem selecionados. Todas as ferramentas ações e menus estarão ativos mesmo enquanto esse diálogo estiver aberto.

Definições - Especifíca cor, suavização, nível de reflexão, transparência, Brilho, e efeito aresta de vidro.

Textura - Aplica atributos de Textura.

Mapas - Aplica atributos de mapeamento.


Material Settings

Definições de Material

Especifica os atributos de Reflexão, Transparência, Polimento, e Relevo para a face.

Cor- Seleciona e define a cor das faces selecionadas.

Suavização - Especifica a Suavização para as faces selecionadas.

Reflectividade - As faces selecionadas podem ter uma superfície parcialmente espelhada refletindo os atores Atmosfera e solo na animação. O grau da reflexão é determinada no indicador. Um valor de 8 atribui uma reflexão de 50/50 entre a superfície e o reflexo.

O Raytrace deve estar ativo nas preferências do Render para funcionar.

Transparência - A textura de vidro usa essa parâmetro. Um valor de 0 é totalmente opaco e de 15 é totalmente transparente. Qualquer face totalmente transparente será completamente invisível. O Efeito aresta de vidro escurece o vidro se estiver ligado.

Transparência está intimamente ligada com o lustre. Quando o objeto apresenta um alto lustre as arestas com curvaturas exibirão brilhos característicos de vidro, tornando o objeto bastante real.

Polimento- Ajusta o Intensidade do brilho se a caixa estive ticada. um valor baixo deixa o foco largo e um valor alto deixa o foco menor e mais brilhante.

Metais são lustrosos mas cromado é mais lustroso que aluminio. É isso o que o valot do Foco reluzente trata

Intensidade do brilho - Se desligado a superficie terá uma aparência opaca. O tamanho é ajustado no indicador.


Shader Attributes

Atributos da textura

Aplica algoriticamente texturas nas faces selecionadas.

Alterações podem ser previsualizadas na vista câmera pressionando o botão Previsualizar.

Cor secundária - Especifica a cor secundária usada pela textura. A cor primária é especificada nas definições.

SelecioneSelect either the Internal check box or the Plug In Texture check box to choose the Texture Type to apply from a list of Internal Textures or from the directory of Plug-in Textures.

Parameter - The Parameter sliders adjusts the parameters the Clouds, Bumpy, Aztec, Wrinkled, Agate, and Dents textures. For example, bumpy textures such as Bumpy, Aztec, Wrinkled, Agate, and Dents use this parameter to set the height of the bumps. The larger the slider value the higher/deeper the bumps.

Texture Axis - Set button is used to apply one of the texture axes to the selected faces. The Set button is disabled and defaults to the Base Axis unless additional texture axes have been added. Up to 64 separate texture axes can be present in each model.

The Move button will activate the Move Texture Axes mode.


Map Attributes

Atributos de mapeamento

Aplica mapeamento as faces selecionadas.

Alterações podem ser previsualizadas na vista câmera pressionando o botão Previsualizar.

Botão definir - Aplica um mapeamento específico nas faces selecionadas.

Botão editar - Edita as características do mapeamento.

Botão atribuir - Atribui um mapeamento a partir das faces selecionadas.

Botão mover - Move um mapeamento nas faces selecionadas.

Mosaico Especifica que o mapeamento não será repetido no modelo.
Especifica que o mapeamento deverá se repetir em toda a extensão da superfície.

Sombramento Renderiza o mapeamento com efeitos de iluminação.
Renderiza o mapeamento ignorando os efeitos de iluminação. Por exemplo: a tela da TV.

Decalque Renderiza o mapeamento normalmente. A cor do fundo do mapa sera renderizada.
Ativa a renderização recortando o mapeamento de modeo que a cor escolhida seja ignorada tornando-se transparente. Use por exemplo para representar um rótulo numa garrafa.


Default Material

Material padrão

Define os atributos aplicados a novas faces criadas.

Cor da face- Esta é a cor que as faces no modelo serão apresentadas na animação.

Cor da textura- Esta cor pode aparecer sobre partes das faces se elas tiverem textura de dois tons. Por exemplo, no mármore ela define a cor de fundo e as veios pela cor principal.

Suavização - Suaviza as faces selecionadas disfarçando as dobras do modelo.

Brilho- Aplica um brilho nas faces selecionadas. Se desligado, a superfície apresentará uma superfície fosca. O tamanho do brilho é ajustado no parâmetro brilho.

Metais são brilhantes mas um cromado possui brilho diferente de alumínio. Basicamente, quanto mais brilho vc atribuir menor será o tamanho do brilho com a impressão de ele ser mais polido.

Opacidade- Um valor de 0 indica que as faces são opacas, um valor de 15 indica que são totalmente transparentes. Note que a informação de brilho será mantida.

Relevo serve para definir a altura simulada do relevo quando vc usa texturas especiais de relevo.

Refletir para atmosfera/solo- As faces selecionadas podem ter uma propriedade de reflexo parcial para refletir o objeto atmosfera ou solo. O grau da reflexão é definida pelo "slider". Um valor de 8 faz uma mistura de 50/50 entre a superfície e a reflexão.


Maps

Mapeamento

Provê vários comandos para edição e posicionamento de mapeamento.

  • Editar mapeamento
  • Mover eixo do mapeameno
  • Eliminar mapeamentos não usados
  • Nova pasta para todos os mapeamentos


Edit Image Map

Editar mapeamento

Esta ação habilita vc criar e editar o mapeamento.

Note que mapas não são atualmente aplicados as faces selecionados a não ser que elas sejam definidas na Definições de material.

A caixa de diálogo será exibida como abaixo. Selecione o tipo de mapeamento, mapas a serem usados, posição e eixo do mapeamento. As mudanças podem ser pré-visualizadas na Janela Câmera pressionando o botão Previsualizar na parte superior direita do diálogo.

Qualquer combinação de um Mapa de superfície, Mapa de Reflexão, Mapa de relevo, e/ou Mapa de Transparencia pode ser definido como um mapeamento. Os mapas talvez sejam imagens estáticas ou sequências animadas. Os ajustadores à direita especificam a porcentagem do mapeamento visível relativo a textura ou superfície.

O tipo do mapeamento pode ser Planar, Cilindrico, Esférico, ou Fixado,

Cor do Decalque - Especifica a cor que é transparente para o decalque. Preto ou branco é usado se a chave índice estiver ativa. A cor especificada na chave cor é usado se estiver ticado.


Move Map Axes

Eixo de mapeamento plano

Permite a vc posicionar uma imagem plana, cilindrica ou esférica no modelo 3d.

A área envolvida pelo mapeamento é definida por 3 manipuladores:

Superior Esquera (S/E) | Âncora move todos os eixos
Superior Direita (S/D) | Redefine a dimensão do raio
Inferior Esquerda (I/E) | Redefine a dimensão da altura.

Alterando esses manipuladores para as posições desejadas simultaneamente na vista OpenGL a modificação será exibida.

Vc pode travar um manipulador na localização do Cursor3D pressionando o botão correspondentes na paleta travar.

Veja mais:

Mapeamento cilindrico.

Mapeamento plano.

Paleta Travar.


Purge Unused Maps

Eliminar mapeamentos não usados

Apaga os mapeamento na cena que não estão relacionados a nenhuma face.


New Folder for All Maps

Nova pasta para todos os mapeamentos

Ativa uma nova pasta que conterá todas as imagens usadas na cena.


Glue Mapping

Mapeamento fixado

Mapeamento fixado faz uma espécie de colagem da imagem ou textura na superfície do objeto. Quando as superfícies sofrem uma distorção ou morfose a imagem acompanha essa distorção.

Ligado | O efeito de colagem será visível.
Desligado | O efeito será nulo e o mapeamento original será atribuido.

Mapeamento fixado cobre a superfície de um modelo através de duas dimensões apenas. Essas duas dimensões não tem nenhuma relação com o sistema de coordenadas globais do OFX(x,y,z), e por isso são chamadas de coordenadas UV.

Quando o mapeamento fixado é aplicado aos vértices, as coordenads se mantém inalteradas, não importa como os vértices são manipulados. Quando o mapeamento é aplicado à superfície, então o mapeamento vai mover ou distorcer para seguir os vértices.

Há 3 métodos básicos para aplicar coordenadas à faces:Aplicando coordenadas de mapeamentos existentes, Atribuindo coordenadas manualmente, e automaticamente aplicando coordenadas usando ferramentas e ações.


Convert Normal Map to Glue Map

Converte mapeamento normal para mapeamento fixado

Este é um modo simples e rápido para aplicar coordenadas de mapeamento aos vértices selecionados. Ele é ideal para casos onde há distorções do modelo ou onde ele for usado como uma morfose, mantendo o aspecto do mapeamento.

Para converter siga os passos:

1) Crie um mapeamento plano ou cilindrico usando Atributos > Mapeamento > Editar mapeamento. Ele pode ser qualquer mapeamento, não necessariamente o único que vc está atualmente usando para renderizar, porque nos estamos somente usando informações de coordenadas de mapeamento.

2) Posicionar o eixo do mapeamento nos vértices e faces selecionados.

3) Execute o comando Atributos > Fixar para mapeamento > Converte mapeamento normal para mapeamento fixo e escolha o mapeamento a ser convertido. Especifique se ele será Plano ou cilindrico.

E isso. Não é necessário manter o mapeamento pois agora as coordenadas serão gravadas nos vértices e poderão manter-se até as coordenadas ou os vértices serem apagados.

Note que isto somente se aplica a vértices. Para aplicá-lo aos vértices selecionados vc precisa definir o mapeamento no diálogo definições de material e especificar que o tipo de mapeamento está fixado através do diálogo Editar mapeamento .


Map Path Vertices

Mapear vértices no caminho

Gera um mapeamento 'colado' quando se usa as ações Duplicar , Extrusão , Extrusão no caminho , Tornear , e Girar .

Nota: antes de ler entenda a explanação sobre Sistemas de coordenadas UV para mapeamento.

Todas a ferramenta e ações trabalham copiando mapeamento de vértices aumentando o valor V(vertical). Normalmente a cada início de uma curva ou caminho. Nós temos um meio de definir as coordenadas dos vértices na curva para criar uma mapeamento 2D. A melhor forma de apreender a trabalhar com essa função é através de experimentos.

Coordenadas na repetição linear


Set Vertex Mapping

Definir mapeamento de vértice

Permite definir um grupo de vértice possuir as mesmas coordenadas de mapeamento UV.

Por exemplo: suponhamos que vc precisa ter um retângulo mapeado onde o mapa é comprimido para baixo e esticado para cima, um caminho para fazer isso é criar um retângulo e subdividi-lo com 9 vértices, como ilustrado abaixo. Então usar um mapeamento planar para aplicar as coordenadas nos vértices como mostrado na figura a direita.

Selecione os 3 vértices na linha central, e modifique a coordenada vertical para 0.3.

Quando renderizado o mapeamento irá aparecer comprimido embaixo e esticado em cima. A aparência horizontal fica inalterada.


Shaders

Texturar

Texturas são algorítimos que matematicamente define a aparência de uma forma ou superfície.

Escolha o tipo de textura para aplicar a partir de uma lista das texturas internas ou da pasta de extensões de textura .

Veja mais:


Move Shader Axes

Mover eixo da textura

O Eixo da textura é usado para especificar o tamanho da textura e orientação relativa as faces selecionadas

Todos os modelos possuem por padrão um eixo de textura. Toda textura possui um unidade de repetição básica que é o tamanho do eixo da textura. Algumas possuem um ponto de origem definido com a textura madeira com o centro dos aneis.

O tamanho e orientação é manipulado com:

Superior esquerdo (S/E) | Move o centro dos eixos e define a posição da textura.
Superior direito (S/D) | Redimensiona a largura
Inferior esquerdo (I/E) | Redimensiona a altura

Experimente com os efeitos esse manipuladores.

Alterando esses manipuladores para as posições desejadas simultaneamente na vista OpenGL a modificação será exibida.

Vc pode travar um manipulador na localização do Cursor3D pressionando o botão correspondentes na paleta travar.

O Parâmetro da Textura é usado para especificar a altura/profundidade da textura.


New Shader Axes

Novo eixo de textura

Adiciona um eixo de textura ao modelo para usar múltiplas texturas.

Visto que o modelo precisa usar várias texturas, o eixo padrão pode não estar numa posição aceitável para algumas texturas. Esta opção atribui eixos adicionais no modelo. Quando uma textura é aplicada às faces no modelo ela pode se indentificar com um eixo especifico de textura que poderá ser usado para alinhar essa textura nas faces aplicadas.

Entre o nome para o novo eixo na caixa de diálogo.

Aplica o novo eixo de textura para as respectivas partes do modelo pressionando o botão na caixa de diálogo dos atributos de material na tabela textura.


Delete Shader Axes

Apaga uma das adicionais texturas

Escolha a textura na caixa de diálogo.

A base não pode ser apagada.

A Textura base é somente usada para definir a base para a pseudo sombra. Veja Lançar sombras .


Preview Shaders

Previsualizar texturas

Previsualiza a aparência das texturas e outros atributos da superfícies.

Um cubo e uma esfera podem rapidamente ser renderizado para mostra o efeito. O cubo é maior que a esfera portanto as texturas irão aparecer menores no cubo.

A escala da textura altera o tamanho do eixo da textura relativo a esfera ou cubo.


Plug-in Shaders

Extensões de textura

Acesse o menu Atributos-> Textura-> Extensões de textura e a seguinte caixa de diálogo aparecerá:

Pressione o botão ler para selecionar uma textura externa.

O Botão editar altera parâmetros da textura relacionada.

Se a textura for atribuida de um modelo todas as faces texturadas com aquela textura expecífica serão convertidas para a cor plana.


Plug-in Shader Types

Extensões de textura

Exibe extensões adicionais feitas por terceiros. Algumas podem estar em inglês ou outra lingua se forem programados assim, pois tratam-se de programas externos e alguns podem ser freeware shareware ou comprados.

Elas possuem grande controle de textura para produzir muitos efeitos interessantes.Veja a lista de alguns exemplos aqui


Untitled Document

Plug-In Textures

This is a list of the other plugin-textures that have help information. There may be others!

Blisters...


Set Model Center

Definir ponto pivô

Move o Ponto pivô (grande cruz amarela) do modelo para a posição do Cursor3D .


Set Follow Point

Definir ponto perseguidor

Move o Ponto perseguidor do modelo (pequena cruz vermelha) para a posição do Cursor3D .


Shadow Casting

Lançar sombras

Use este comando para ligar ou desligar a sombras lançadas de modelos para modelos.

Calcular sombras no espaço 3d consome muita memória.

Devido o objeto solo ser sempre plano, sombras são facilmente calculadas sobre ele e chegam perto da perfeição.

Lançar sombras em modelos é mais complicado. Use luzes spots e planos de sombra.

O plano de sombra é definido pela posição e orientação do eixo base da textura.Veja: Texturas

Veja o armazenamento da sombra quando aplicar luzes spots na cena.


Mirror Plane

Plano espelho

Cria uma imagem espelho em todas as suas faces que são refletivas.

Plano espelho não é necessário se a imagem for renderizada com o Raytrace ligado.

Um renderizador por mapeamento não produz reflexões, mas usando esse recurso qualquer superficie plana na sena pode ter uma aproximação da reflexão real. (O renderizador por mapeamento é muito mais rápido do que o Raytrace).

Plano espelho desligado | Plano espelho ligado

A mirror plane reflection works in a similar way to reflection in the ground plane but setting it up takes a little more work because unlike the ground which is always flat a mirror plane can be horizontal, vertical or lie at any angle at all.

Any triangular faces that are reflective and lie in the mirror plane will show a true reflection.

The mirror plane is specified by adding a texture texture axes which acts to define the plane of the mirror. Executing the Mirror Plane menu command offers you a selection of texture axes - choose one of them.

Notas:

  • Um modelo pode usar somente um plano espelho ao mesmo tempo mas muitos modelos com planos espelhos podem ser animados juntos.
  • Planos solo extendem para o infinito portanto ele não trabalha em uma cena contendo modelos que usam planos espelho.
  • Se vc precisa ter um plano solo na animação que usa modelos com planos espelhos vc precisa simular o solo com um plano que seja escalonado para preencher o horizonte, caso seja necessário.
  • Para desligar o plano espelho atribua a ele nenhum eixo de textura. Durante a renderização vc verá cada reflexão renderizar em separado e então composta no final para criar a imagem definitiva.
  • Lembre-se que um espelho somente reflete objetos que faceam ele.


Refractive Index

Índice de refração

Especifica o Indice de refração para as faces selecionadas.

Refração somente é calculada se o Traçar refrações e Traçar Reflexões estiver ligado na caixa de diálogo do Renderizador.

Refração é usado para simular superfícies transparentes com desvios de luz. Como uma garrafa ou copo por exemplo, a qualidade depende do tipo de material que vc que usar, a tabela abaixo lhe dá uma ideia de com ajustar o índice.

Material | Indice de Refração
Ar | 1.0 (Sem refração)
Vidro | 1.2 - 1.9
Água | 1.33 (1.3 para gelo)
Diamante | 2.4


View Menu

Menu Vista

Funções relacionadas as vistas dos planos.


Hide Selected

Ocultar selecionados

Oculta vértices, arestas, e faces selecionadas da vista.

Eles não são afetados nesse estado por nenhuma ferramenta ou ação.


Reveal Hidden

Revelar ocultos

Revela todos os vértices, arestas, e faces que estão ocultados.


Hide Edges

Ocultar arestas

Oculta todas as arestas (selecionadas e deselecionadas) no modelo nas vistas superior, anterior e laterais com o objetivo de acelerar a manipulação das vistas.


Hide Joins

Ocultar ligações

Oculta as arestas das ligações.


Show Grid

Exibir Grade

Liga e desliga a grade nas vistas.

Existem 3 elementos na grade:
1. | O eixo do sistema de coordenadas, representado pela cor branca, mostra a posição (0,0,0).
2. | Uma grade com linha contínua determina cada unidade padrão da grade.
3. | Uma grade com linha tracejada representa a unidade dividida por 10 partes e sempre nesse intervalo num zoom maior (intervalo de 0.1).

E a cada Zoom- a grade mudará para um unidade a cada 10 ampliadas, até o máximo Zoom.

O tamanho da grade é estabelecido nas Definições da grade.


Snap to Grid

Travar na grade

Trava o Cursor3D nos pontos da Grade. A grade pode estar visível ou não.

Use a Grade 3D para mover o Cursor3D em passos quando desenhar, mover, etc.

É afetado pelo zoom.


Grid Settings

Definições da grade

Define o tamanho da grade e se ela será visível.

O tamanho da grade é definido pela unidade atual.


Display Coordinates

Exibir coordenadas

A paleta das coordenadas aparecerá.

Exibe as coordenadas quando o Cursor3d for movido. Escreva para mover o cursor3d relativamente ou absolutamente.

Move o Cursor3D para as coordenadas definidas na caixa. A entrada de de valores relativos(delta, or dX, dY, dZ) automaticamente atualiza a coordenada absoluta e vice-versa.
Redefine as coordenadas (em unidades do cursor) do Cursor3D. Desfaz qualquer entrada de valor para as coordenadas.
Define a origem das coordenadas na posição do Cursor3D.
Define a unidade atual e nomea o sistema de coordenadas. (a unidade padrão é cm). As unidades são definidas relativamente ao tamanho da área de trabalho do programa.


3D Cursor

Cursor 3D

O Cursor 3D é usado para indicar uma posição exata no espaço 3D. Ele é posicionado nas vistas Superior, Anterior e laterais através do cursor do mouse (clicando numa área)

O Cursor 3D pode ser mostrado como uma cruz ou um alvo. Vc pode alternar usando a tecla F9.

Cursor 3D em cruz

3D Cursor 3D em alvo


Window Menu

Menu Janela

Opções e funções para controlar as janelas.


Zoom In

Zoom +

Amplia a vista.


Zoom Out

Zoom -

Reduz a vista.


Set Default Zoom and Position

Definir zoom e posição padrão

Reinicia as posições e tamanhos padrões do módulo Designer mantendo o trabalho inalterado. É útil para comparar as escalas de modelos feitos separadamente.


Swap Viewpoint

Alternar vista única

Vc deve ter percebido que aparece a vista superior, lateral e posterior. Onde estarão as outras. Usando essa opção vc pode vê-las. Se a vista ativa for a superior ela trocará pela inferior, se for a posterior trocará pela anterior, se a lateral trocará pela outra lateral, e vice-versa.


Reset Quad View Windows

Reiniciar quatro vistas

Volta as vista para os parâmetros da inicialização.


Hide OpenGL Camera View

Ocultar vista OpenGL

Desliga ou liga a vista OpenGL

Vc pode também dar um clique direito com o mouse na vista camera para alternar para a OpenGL

OpenGL Ligada

OpenGL oculta


Viewer

Visualizador

Um programa para exibir imagens GIF, BMP, Targa, TIFF, e JPEG.


Animator

Animador

Exibe o módulo Animador.

O módulo Designer não é fechado e os modelos continuam na RAM.


ViewOpenGL Menu

Menu vista OpenGL

Opções e configurações da vista OpenGL e CâmeraGL.


Update Mapping

Atualizar mapeamento

Atualiza na vista OpenGL qualquer alteração nos atributos do mapeamento das faces do objeto.


Two-Sided Polygons

Polígonos com dupla normal

Renderiza o polígono com os dois lados visíveis, interno e externo.

Na maioria dos programas 3D e renderizadores, incluindo o OpenGL, renderiza um lado da face como sendo visível e o outro invisível. O lado visível é a norma da face, com essa opção vc define que os dois lados da face são normais.


Scrollbars Visible

Visualizar Barras de rolagem

Exibe as barras na Vista Câmera.

São usadas para posicionar o modelo na vista.


About

Sobre

Exibe a versão atual do produto.


Help Menu

Menu ajuda

Chama as ajudas do Designer.


Animator Help

Ajuda do Designer

Exibe a ajuda do módulo Designer.


General Help

Ajuda geral

Exibe a ajuda geral do sistema.


About The Designer Modeler

Sobre o Designer

Exibe o número da versão atual do módulo Designer.


Renderer Help

Ajuda do Renderizador

O Renderizador é o módulo que cria as images sequênciais para montar a animação.

Render consome tempo de processamento de acordo com as opções determinadas na caixa do Render.


3D Plot Tool

Ferramenta Lápis

Ela cria em 3D vétices e Arestas no espaço dentro da janela da vista.

Os vértices são criados na posição do Curso 3D e conecta-se ao próximo vértice criado.

Mova o cursor 3D próximo do lugar onde vc deseja iniciar a curva. A curva pode iniciar-se num vértice previamente selecionado sendo assim soldada ao mesmo, faça isso posicionando o cursor 3D próximo do vértice selecionado. Mantenha o botão esquerdo pressionado e clique o direito para soldar ao vértice ou para criar um novo vértice numa posição onde não existe um vértice, arraste então para a posição desejada do próximo vértice criando assim uma aresta até o primeiro. Caso for clicado em cima de um vértice selecionado a aresta será soldado a ele. Se as arestas ao redor formarem um triângulo então uma face será definida no local. Use CTRL para desabilitar a soldagem automática.

Enquanto defini uma curva 3D, vc pode mover entre as três vistas da área de trabalho do Designer, posicionando assim os vértices em qualquer eixo do espaço 3D


Terms used in the Animator

Termos usados no Animador

Cursor3D - Um programa bidimensional possui um único cursor, mas quando trabalhamos no espaço 3D precisamos de um cursor adicional que possa trabalhar nas três dimensões espaciais. Ele pode ser colocado em qualquer lugar do espaço 3D com o ponteiro do mouse.

Ator - Um ator é o termo usado para cada elemento na animação. Um ator possui um Avatar (personificação), o avatar é mutável na animação o ator é constante. Há 12 tipes de atores. O mais importante é o tipo modelo. Uma ator modelo usa um avatar que é um modelo criado no Designer. Para entender isso imagine uma aeronave voando sobre uma cidade seguindo um caminho pré-definido, a aeronave é o ator modelo usando uma avatar de um caça F15, imagine que na verdade deveria ser um F117 na animação, para acertar basta apenas trocar o avatar do ator modelo aeronave por uma avatar de um modelo de F117. Modelos são gravados com a extensão de arquivo .MFX.

Trilha do ator- É o caminho que o ator seguirá durante a animação. Uma trilha somente será visível se houver duas linhas do tempo de movimento que sejam contíguas.

Janela ativa - É a vista que está atualmente em foco. Ela é iluminada por um contorno amarelo. Pressione Tab para caminhar pelas vistas, clique com o mouse numa vista para torna-lá ativa.

Ponto pivô - Cada modelo tem um ponto usado no animador para manipular o modelo. Por exemplo se um modelo for uma aeronve seguindo um caminho o ponto do modelo que exatamente segue o caminho é o ponto pivô.

Linha do Tempo - Para direcionar a atividade de um ator na animação é requerido o uso de 4 linhas do tempo, avatar, posição, rotação e tamanho. Uma linha do tempo expande um número de quadros e possui um quadro-chave associado a eles. O quadro-chave é o quadro onde a ação do ator é exatamente especificada, enquanto que nos outros quadros intermediários o programa calcula sozinho baseado na interpolação dos valores.

O quadro-chave sempre será o último quadro na linha do tempo. Uma linha do tempo é o intervalo de quadros onde o ator efetua as ações determinadas pelo quadro-chave.

Linha do tempo expandida - É o quadro atual se ele na linha do tempo é menor igual ao quadro atual e se o último quadro na linha do tempo é maior ou igual ao quadro atual.

Avatar - Para ser visível na animação um Ator precisa possuir um avatar. O tipo de ator dita que sorte de avatar ele pode possuir, mas atores podem mudar de avatar durante a animação.

Quadro atual - É o quadro na animação que é exibido na vista e onde qualquer mudança pode ser feita.

Curva - Um conjunto de vértices concectados por arestas sem formar nenhuma face. Curvas podem ser abertas ou fechadas.

Aresta - Um seguimento de reta conectando dois vértices.

Face - Uma superfície triangular definida por 3 arestas unidas exatamente por 3 vértices .

Ponto perseguidor - Uma localização (Especificada no Designer) no modelo onde outro objetos podem seguir.

Quadro - Igual a convenção cinematográfica de quadros para cinema e animação. Pode ter imagens em seguência na proporção por exemplo de 24 quadros por segundo. Cada quadro é composto de uma imagem.

Matiz Plástico - Um algorítimo de renderização que sombrea o modelo misturando e desfocando superfícies adjacentes. É usado pela vista OpenGL.

Mapeamento imagem - Um mapeamento imagem é um arquivo GIF ou TGA que será usado para "pintar" faces do modelo adicionando decalques detalhados na superfície.

Indicado - Para escolher um particular vértice, aresta, face, ou objeto para ser afetado por uma operação sem seleciona-lo coloque o Cursor3D sobre ou próximo a ele (entre um ou dois "pixels") para ser indicado. se mais de um elemento está indicado então o mais próximo do cursor3D será usado.

Quadro-chave - Um quadro chave é o quadro onde algumas informações são especificadas sobre a atividade do ator. O conceito é igual ao dos desenhos animados onde o desenhista mestre determina as partes importantes da animação e os desenhistas de produção fazem os quadros intermediários, aqui no caso feito pelo programa.

Q-chave - É a barra inferior do Animador onde é exibida as linhas do tempo (avatar, posição, rotação e tamanho) do ator atual. Onde vc pode inserir e modificar os quadros-chaves da animação.

Modelo - É unidade principal da estrutura. Um modelo é feito por faces e cada face é determinada por três arestas. O tamanho, posição e orientação da face é determinada pelos vértices que a definem.

Chaves de modificadores - O Shift, Ctrl e Alt são usados para modificar a ação das ferramentas do Designer. Se um ou outro é usado então a ferramenta é modificada apropriadamente.

Morfose - Proporciona que um modelo se transforme em outro.

Nó - Um nó é um ponto em um caminho ou robô que pode ser manipulado. E representado por um pequeno quadrado.

Origem - A origem padrão são as coordenadas de valores (0, 0, 0).

Caminho - Uma Curva que é usada no Animador como caminho para os atores seguirem (.PTH). E pode ser usado no Designer para definir uma extrusão.

Matiz esmalte - Um algorítimo de renderização que sombrea um modelo suavizando e descreve superfícies, texturas e propriedades de reflexão e pode simular espelhos. O Render usa essa matiz como padrão se o raytrace não estiver ativo.

Suavizar - Esse é um procedimento que ajuda a remover a aparência facetada da superfície de um modelo.

RayTrace - Um complexo sistema de renderização capaz de criar efeitos espelho, transparências, sombras, e refrações.

Status da Seleção - Cada vértice no modelo pode ter um desses estados: Selecionado, Deselecionado, Oculto. Selecionado vértices são manipulados pelas ferramentas e ações. Deselecionado Vértices não são afetados pelas ferramentas ou ações. Oculto vértices não são exibidos e não são afetados.

Textura - Uma textura é um algorítimo que pode adicionar finos detalhes a superfície do modelo. Exemplos são madeira e Mármores. Eles não dependem de uma imagem pois são gerados matematicamente.

Esqueleto - O esqueleto e os nomes hierárquicos são a mesma coisa. O esqueleto é um termo usado para facilitar a compreensão do sistema de vértices que podem deformar partes de um modelo.

Ligação do esqueleto- O esqueleto é formado por um número de ligações, cada ligação tem um Osso associado e um nó no seu fim. Cada osso é amarrado a outra articulação no nó ou "raiz".

Intensidade de brilho - O polimento de uma superfície é simulado pela intensidade de brilho. Basicamente quanto mais polida uma superfície maior será a intensidade de brilho que ela possuirá.

Vértice - Um ponto distinto no espaço 3D representado por um ponto amarelo ou vermelho se selecionado ou deselecionado respectivamente.


Auto Filling

Auto Preenchimento

Cria faces (Facetadas) para preencher um espaço cercado por vértices selecionados usando os comandos Ações> Preencher contorno ou Ações> Preencher no Cursor

Auto preenchimento é de longe a forma mais simples para facetar um objeto, mas nem sempre é apropriado. Para usá-lo, desenhe um contorno com a Caneta , lembrando de fecha-la, (A Caneta poderá fechar a curva se vc clicar exatamente em cima do primeiro vértice criado). Então, com todos os vértices da curva selecionados, centralize o Cursor3D e escolha Preencher no Cursor no menu Ações. A curva será mostrada agora como um sólido. Vc pode observar isso tornando ativa a vista OpenGL. A vista OpenGL somente exibe faces preenchidas.

Auto preenchimento tem suas limitações. A principal limitação é que somente formas convexas podem ser facetadas. É possível facetar uma forma côncova, mas tenha cuidado onde for colocar o cursor 3D.


Build Menu

Menu Criar

Funções de criação de formas especiais do Designer.


Center vs. Centroid

Ponto pivô vs. Centro de massa

O centro de um grupo de vértices (ponto pivô) é o ponto médio tridimensional de uma imaginário cubo envolvendo as dimensões do objeto, assumindo que esse cubo está alinhado aos eixos das coordenadas.

O Centro de massa de um grupo de vértices é o centro de gravidade ou a média das posições individuais dos vértices.

Note a posição do centro e do centro de massa no cone abaixo.


Clamped Maps

Mapa em grampo

Exibe na OpenGL os mapas com seus limites definidos nos eixos do mapeamento. Ativado ou desativado nas Preferências da OpenGL.

Mapa em grampo ativado

Mapa em grampo desativado

O OpenGl não exibe mapeamento fixado se o Mapa em grampo estiver ativado.enabled.


Closed Path

Caminho fechado

Um caminho fechado tem loops e precisa ter no mínimo três nós.

Caminho fechado


Curve Definition

Curvas

Uma curva é um conjunto de vértices conectados por arestar sem formar faces. Curvas podem ser abertas ou fechadas.

Curvas podem ser geradas com a ferramenta Desenhar ou Caneta, ou desenhadas pelo editor Build Bezier Curve .

Curva aberta

Curva fechada


Disk Primitive

Primitiva disco

Pela caixa de diálogo, vc pode criar o disco com valores específicos.

Atribua os desejados raio, número de lados, ponto central, e pressione criar. Note que o centro é o ponto no espaço 3D onde o centro do disco será colocado.


Face and Edge Creation

Criação de aresta e face

O tema central do sistema de modelagem baseada em triângulos é o facetamento.

O contorno não preenchido na esq. não será renderizado um vez que não é composto de faces (triângulos) e será considerado um buraco. O contorno preenchido a direita será renderizado como uma superfície.

Existe 2 caminhos para facetar (Criar faces triangulares que definem preenchimento) um contorno ...

Auto Preenchimento | Usando as ações Preencher contorno ou Preencher no cursor
Tecer | Usando a ferramenta Caneta


Import Imagine (TDD) Model

Importar modelo Imagine (TDD)

Importa modelos DOS.


File Open DXF

Arquivo abrir DXF

Abre um arquivo DXF.

Selecione o arquivo e as opções da caixa de diálogo de importação.

O"Conversão em entidades 2D" precisa estar ticada para importar dados DXF 2D.


Fit in Window

Ajustar na janela

Altera o tamanho e posição das vistas para exibir todos os vértice selecionados.


Image Processor Effect Types

Tipos de efeitos de pós-processo

Chamaremos esses efeitos de pós-processo para não confundir com Pós-produção realizado num outro software qualquer para esse fim.

Inserir um efeito na cena através da caixa de diálogo, esses efeitos são extensões:

Desfoque - Simula o efeito de desfoque para simular movimento.

Profundidade do campo (Dof) - Simula o efeito fotográfico que desfoca um elemento da cena e outro não.

Filtros - Muda as cores dos "pixels" depois de compretada a renderização para criar efeitos específicos.

Reflexos de lentes (Lens flare)- Simula o efeito de luzes refletindo nas lentes da câmera.

Neblina - Simula neblinas e nevoeitos.

Aura - Adiciona o efeito de uma aura em volta do objeto.

Auréola - Adiciona uma auréola em volta da luz.

Brilho - Adiciona um brilho como o brilho característico de um diamante refletindo a luz.

Laser - Simula um raio laser.

Campo estelar - Cria um campo estelar com movimento.

Estrelas - Cria um campo estelar fixo.

SuperNova - Simula uma estrela em supernova.

Trilhas - Deixa uma trilha atrás de objetos em movimento na animação.

Video - Possui 24 efeitos de vídeos diferentes.

Xvideo - Possui 26 efeitos de vídeo adicionais.

Veja mais sobre processos especiais.

Bolas de fogo..

Atmosféricos...


Import Model

Importar modelo

Ativa a importação de algum outro formato de modelo.


Internal Shader Types

Tipos de texturas

Textura são criadas na renderização.

Plana | A textura plana é a cor pura sem efeito nenhum na superfície.
Madeira | A superfície ganha a aparência de madeira. A cor primária representa a cor fria, a cor da textura a cor quente.
Mármore | A cor dos veios são atribuídas pela cor primária e o fundo pela cor da textura.
Granito | A cor primária mistura com o preto.
Luminosidade | Simula uma superfície fluorescente. Use-a em lâmpada, abjoures, luminárias, etc. para simular um objeto que emana luz.
Flash | Essa textura exibe a cor da face num brilho máximo por 5 quadros e um mínimo por 5 quadros.dando ao objeto uma ilusão de flash. Use por exemplo nas luzes de navegação de uma aeronave.
Relevo | A textura relevo é muito útil. Ela atribui a superfície uma textura rústica. A intensidade e tamanho vc pode definir pelo parâmetro usando o Indicador do parâmetro da textura.
Azteca | Essa outra textura de relevo representa a superfície com área planas entre os relevos.
Rugas | Uma textura de relevo com efeito de rugas direcionais.
Pontilhado | Uma mistura de pontos irregulares aplicado a superfície.
Agata | Uma textura que imita pedra.
Nuvem | Essa textura simula a aparência de nuvens. Não é afetada pelas condições de luz.
Matelado | Pequenos relevos espaçados e colocados aleatoriamente na superfície.
Combinado | Mistura a partir da cor primária até a cor da textura criando vários traços combinados que podem ser editados.
Madeira++ | Está é mais natural aparência de uma textura de madeira, mas a renderização é muito mais lenta.

Veja mais
Extensões de textura


Loaded Path

Ler caminho

Abre um caminho que foi gravado como um arquivo .PTH, criado no designer anteriormente.

Alguns exemplos de caminhos gravados: Circular.pth, Elliptic.pth, Helix.pth, Parabola.pth, and Spiral.pth.


Lock Palette

Paleta travar

Define a posição de cada eixo de mapeamento pela posição do Cursor3D.

.

Para travar um mapeamento à vértices específicos, pressione o botão travar pressionando o eixo de mapeamento correspondente.

Trava a posição Superior/Esquerda na posição do Cursor3D.
Trava a posição Superior/Direita na posição do Cursor3D.
Trava a posição Inferiro/Esquerda na posição do Cursor3D.
Trva o eixo do mapeamento nos vértices selecionados.
Sai do modo de edição dos eixos de mapeamento.

Importante: Travar não terá efeito se mais que 3 vértices são selecionados.

Veja mais
Eixo de mapeamento plano
Eixo de mapeamento cilindrico


Map Attachment Types

Tipos de mapeamento
Plano O mapeamento plano é aplicado nas faces selecionadas por uma projeção perpendicular de um plano de mapeamento. Imagine o objeto em frente a um projetor de "slides", o resultado será o mesmo, também o 'escorrimento' lateral da imagem. Vc pode usar esse tipo de mapeamento em paredes, portas, mesas, etc.

Cylindrical O mapeamento cilindrico simula uma imagem envolvendo um modelo como um cilindro. Também haverá escorrimento da imagem nas partes superiores e inferiores do cilindro. O mapa é sempres colocado no sentido horário e o ângulo da extensão do mapeamento é definido pelo ângulo de mapeamento cilindrico. Vc pode usa-lo para mapear por exemplo um coluna, cano, foguete, etc.

Esférico O mapeamento esférico aplica um imagem envolvendo ela como uma esfera no modelo. Seu polos compimirão a imagem. Vc pode usá-lo para mapear bolas, bolhas, pedras, etc.

Fixado Nenhum eixo é associado nesse tipo de mapeamento. O mapeamento vai acompanhar a deformidade do modelo. Vc pode usá-lo para mapear formas orgânicas e objetos que sofrem deformação.


Cylindrical Map Axes

Eixo de mapeamento cilindrico

O eixo de mapeamento cilindrico permite a vc posicionar precisamente uma imagem cilindrica no modelo 3d.

A área envolvida pelo mapeamento cilindrico é definida na vista usando 3 Manipuladores:

Superior Esquera (S/E) | Âncora move todos os eixos
Superior Direita (S/D) | Redefine a dimensão do raio
Inferior Esquerda (I/E) | Redefine a dimensão da altura.

Alterando esses manipuladores para as posições desejadas simultaneamente na vista OpenGL a modificação será exibida.

Vc pode travar um manipulador na localização do Cursor3D pressionando o botão correspondentes na paleta travar.

Veja mais:

Mapeamento plano.

Paleta Travar.


Map Axes Planar

Eixo de mapeamento plano

Permite a vc posicionar uma imagem plana no modelo 3d.

A área envolvida pelo mapeamento plano é definida por 3 manipuladores:

Superior Esquera (S/E) | Âncora move todos os eixos
Superior Direita (S/D) | Redefine a dimensão do raio
Inferior Esquerda (I/E) | Redefine a dimensão da altura.

Alterando esses manipuladores para as posições desejadas simultaneamente na vista OpenGL a modificação será exibida.

Vc pode travar um manipulador na localização do Cursor3D pressionando o botão correspondentes na paleta travar.

Veja mais:

Mapeamento cilindrico.

Paleta Travar.


Mapping Types

Tipos de mapeamentos

Mapeamento de superfície - A imagem é aplicada diretamente na superfície. Ela pode ser mixada com as texturas. Uma série de imagens em sequência de arquivo FLI pode ser usado para simular um mapeamento animado.

Mapeamento de reflexão - Uma imagem não é aplicada diretamente na superfície dando a ela uma impressão de reflexão. A reflexão não possui nenhuma orientação particular. Ela não é exata é apenas uma forma de ilusão. Para se ter um reflexo real deve-se atribuir para cada face no diálogo atributos refletividade, assim o objeto refletira os atores atmosfera e solo.

Mapeamento de relevo - É usado para dar a ilusão de irregularidades na superfície. Por exemplo, numa parede de tijolos a vista o tijolo está mail elevado na superfície do que a argamassa entre os tijolos. usando um mapeamento de relevo podemos simular o baixo relevo da argamassa.

Mapeamento de transparência -Varia a opacidade da superfície onde é aplicado. Qualquer parte coberta pelo mapa que seja da cor branca é totalmente transparente, e qualuer parte que seja preto é opaca.


Material Settings Basics

Definições básicas de material

Especifica Cor, Suavização, e Intensidade de brilho para as faces selecionadas.

As modificações podem ser previsualizadas na Vista câmera pressionando o botão Previsualizar.

Cor Aplicada as faces selecionadas - Esta é a cor que as faces no modelo terão quando elas aparecerem na renderização.

Algumas das faces podem ter atributos diferentes. Por exemplo, parte de uma esfera pode ser vermelha e a outra verde. Quando vc entra uma cor ela não é aplicada até que o botão definir seja clicado.

A caixa de diálogo é a caixa padrão do windows para cor podendo escolher da paleta basica ou atribuindo valores nas escalas RGB/HSV.

Botão adquirir - Lê a cor das faces selecionadas e atualiza a caixa da cor.

Botão Definir - Atualiza as faces selecionadas com a cor exibida na caixa da cor.

Cor da textura - Essa cor aparecerá sobre as partes das faces se elas possuirem uma textura de dois tons.

Suavização - Aplica Suavização às faces selecionadas.

Intensidade de brilho- O brilho do lustre da superficie. Se desligado, a superfície terá a aparência opaca.


Move Dialog

Mover

Move os vértices selecionados para uma distância especificada.

Escreva as coordenadas para onde vc deseja mover o objeto. O movimento é relativo ao ponto pivô do objeto.


Objects

Atores (Algumas programas de animações os chama de objetos)

Existem 12 tipos de atores no módulo de animação. Cada ator é representado por um ícone. A Câmera, Luz e Alvo possuem ícones facilmente identificaveis na vista. Os atores Modelo, Morfose, e Robô são representados como cubos limitados, malha ou contorno. Os atores Atmosfera, Efeito de imagem e Diretor não possuem representação, ator CSG é sempre representado por um cubo limitado e o Solo é representado com um ponto, retângulo, ou linha.O Ator Caminho é representado por um segmento de linhas conectadas ou não com nós quadrados.

Nos três primeiros, Modelo, Morfose, e Robô serã visíveis na animação renderizada se eles usarem um Avatar (personificação) e estiverem em frente a câmera no quadro atual. Os Avatars são projetados e desenhados no Designer e que Avatar o ator está usando é especificado na linha do tempo Avatar do ator.

O próximo grupo, Atmosfera, Solo e CSG poderá ser visível sob as mesmas condições mas seus Avatars são muito mais simples para especificar e isso é feito exclusivamente no Animador.

Quando um linha do tempo do Avatar do ator é criada, é colocada no Q-chave ou ou diretamente adicionado no ator, o Animador apresenta uma caixa de diálogo apropriada para especificar coisas como Cor da Atmosfera, Textura do Solo, etc.

Os Efeitos de Imagem são um tipo especial de ator que é aplicado como um pós-processo na renderização final da animação. Eles não são visíveis na janelas das vistas.

Os tipos de atores restantes, Câmera, Luz, Caminho, Diretor e Alvo não são visíveis em renderizações mas são muito importantes na produção da mesma.

Modelo
Esse tipo de atou usa um Avatar que é o modelo desenhado no Designer. Um Ator Modelo pode usar um Avatar na animação, onde ele é especificado na linha do tempo relativa. Qualquer mudança do avatar altera a linha do tempo. Se um ator mudar seu avatar, e ambos forem compatíveis, o ator será instruido para morfosear gradualmente para o outro.

Morfose
O ator Morfose usa um avatar desenhado no Designer, mas 2 ou mais modelos podem ser especificados juntos para a morfose. Um conjunto de modelos são manipulados com uma simples entidade. Eles são muito práticos quando for necessário usar uma sequência de várias morfoses na animação.

Câmera
Ator Câmera provê os 'olhos' que verão a ação. Pelo menos uma câmera deve haver, outras podem existir mas uma de cada vez é apresentada na vista câmera.

Alvo
Alvos são usados como um ponto para apontar a câmera e definir ações que precisam ocorrer no mesmo lugar em tempos diferentes.

Luz
O Ator Luz provê iluminação para a animação, se múltiplas luzes estão presentes então é uma boa idéia escurecer algumas. Luzes podem lançar sombras sem adicionar nenhuma iluminação ou vice-versa. Luzes spots possuem um cone que lança sombras fotorealísticas.

Caminho
Um ator caminho é usado por outros atores para movimentar relativo a ele. A velocidade de cada ator movendo no caminho é definido pela Velocidade . Caminhos podem ser abertos, fechados or lidos a partir de um arquivo PTH. Caminhos não são visíveis na renderização.

Atmosfera
Um Ator Atmosfera se forma no fundo da animação. Somente um ator Atmosfera é permitido por animação.

Solo
Um plano Solo é uma superfície sólida horizontal que e extendida ao infinito em todas a direções. Pode possuir multiplos avatares, texturas e imagens aplicadas mas somente um ator desse tipo é permitido. Nas vistas ele é representado como uma linha horizontal. Um retângulo representa o solo na vista superior, e pode ser movido, rotacionado ou escalonado na linha do tempo apropriada.

Efeito de pós-processo
Modifica uma cena previamente renderizada. Exemplos de efeitos são Reflexos de lentes, Efeitos especiais de video, Neblina, etc.

Robô
O Ator Robô usa um modelo que possui um esqueleto. O esqueleto pode ser manipulado no linha do tempo do avatar. O esqueleto movimentado distorce o avatar do modelo para representar uma animação. Se o Ator está selecionado a ferramenta selecionador de vértices pode ser usado para selecionar as ligações do esqueleto do ator.

CSG
CSG Ator representa algumas geometrias básicas que possuem superfícies curvas que requerem um número muito grande de faces para uma renderização mais suave.CSG pode ter esferas, discos, cilindros, ou tubos como avatares. Nota: Atores CSG não podem lançar sombras ou aparecerem em reflexosmes. A first order subtractive intersection can be arranged between solid CSG's. Note: CSG Actors do not cast shadows or appear in reflections.

Diretor
O Ator diretor é usado para especificar qual câmera ésta ativa. Na linha do tempo do Diretor a câmera padrão está ativa. Somente um diretor pode existir em cada animação. Cada linha do tempo do Diretor indica uma câmera: Para trocar a câmera e quando ela estará ativa na animação, escolha na Q-chave a câmera que deseja usar.


Open Path

Caminho aberto

Um caminho aberto possui pontos iniciais e finais distintos. Precisa ter pelo menos dois nós.

Open Path

Note que Nó/ferramenta Vértex pode ser usada para modificar a forma e números de pontos no caminho.


Path Definition

Caminho

Um caminho é um conjunto de vértices conectados por arestas sem formar faces. Caminhos podem ser abertos ou fechados.

Caminho podem ser gerados usando a Ferramenta Caneta ou Ferramenta Lápis ou ainda com o editor Criar Curva Bézier .

Caminhos são usados pelo Designer para fazer extrusões.

Caminho Aberto

Caminho Fechado


Path Velocity Curve

Velocidade no caminho

O Editor de trajeto controla a velocidade e direção de um Ator no Caminho.

Aceleração e desaceleração podem ser controlados aqui.


Phong Smoothing

Suavização

Esse é um procedimento que remove a aparência facetada de superfícies curvas de modelos.

O diagrama abaixo mostra um cilindro suavizado e um facetado.

Quando condições de iluminação são aplicadas a um objeto facetado, as sombras resultarão em algo como:

Isso ocorre porque superfícies de triângulos são planas. Quando aplicamos a suavização, os cantos das faces, principalmente alguns daquelas que formas ângulos obtusos, o sombreamento ocorrerá de forma homogênea para aproximar quanto for possível a uma superficie curva.

compare abaixo os resultados: com um cilindro real e um cilindro suavizado.

Note que os cantos que formar um ângulo igual ou menor que noventa graus não são suavizados.

If possible, smoothing should only be applied to faces with angles of 60 degrees or less (to adjacent faces). You must be quite selective in which faces you choose to apply smoothing too.

A few more words need to be said about the problem that was hinted at earlier with regard to the cylinder.

There will be no problem (with angles) in smoothing the curved surface of the cylinder provided 6 or more edges around a circular end were used (12 triangular faces on the curved surface). However it is desired to retain the crease between the top surface and the side, and of course at the bottom as well.

To achieve this smoothing should be applied to the faces on the curved surface only.

For a cylinder such as the one shown below this can be done by selecting all the vertices that make up the cylinder and then setting smoothing to OFF. Then, by using the Selector (in a window which show the circular section), the vertices at the center of the top and bottom surfaces are selected. Finally by clicking on the Select Swap icon the appropriate vertices are selected. Smoothing is activated for faces in the Designer's Attributes dialog.

Quando deseja suavizar várias superficies que formam angulos proibidos separe a superfície desejada da outra criando um chanfro entre elas e então aplique a suavização.

Canto comum

Chanfro (Um canto para cada superfície)

Para aplicar a suavização a faces específicas, selecione-as somente elas.


PlugIn Actions

Extensões de Ação

Exibe extensões adicionais feitas por terceiros. Algumas podem estar em inglês ou outra lingua se forem programados assim, pois tratam-se de programas externos e alguns podem ser freeware shareware ou comprados.

As extensões precisam estar na pasta do Designer.

Veja alguns :
Simplify...
Tesselate


Postscript Text Builder Utility

Utilitário de criação de texto Postscript

Possibilita a criação de texto 3D para logotipos usando fontes Postscript.

Previsualizar forma -Mostra a forma da fonte.

Visualizar pré-arquivo - Previsualiza o resultado da projeção do texto 3D.

Ponto de influência - Define o eixo de rotação da fonte.

Botão Escolher - Seleciona a fonte Postscript.

Texto - Entre aqui o texto desejado.

Chanfro anterior - Coloca um chanfro na parte frontal das letras.

Chanfro posterior - Coloca um chanfro na traseira das letras.

Ângulo do chanfro - Define o ângulo do chanfro, que dependerá do tipo de fonte de forma a evitar interseções que causarão falhas na forma.

Profundidade do Chanfro - Define o tamanho do chanfro.

Largura - Define a largura da fonte.

Preencher anterior e posterior - Gera uma superficie nos lados frontal e traseiro da fonte.

Não preencher - Gera a fonte com buracos.

Mostrar da esquerda para a direita - Cria os caracteres na forma de leitura normal. Exemplo: Logo

Mostrar da direita para a esquerda - Cria os caracteres na forma inversa de leitura. Exemplo: ogoL

Defina também a cor da fonte e do chanfro e pressione criar.


Quick Render

Renderização rápida

Clique direito na vista Câmera e escolher Renderização rápida ou usar F12. A renderização mostrará, mapeamento, texturas, reflexos, etc.

Note que a opção no menu não estará disponível se o recurso Sombreamento via OpenGL estive ligado.

Dica: Renderização rápida será mais rápida se o monitor estiver no modo 16 milhoões de cores.


Renderer Overview

Renderizador

Selecione as definições desejadas para a renderização no Controles, Opções, Definições, e Raytrace . Pressione o botão Render para iniciar o processo.

Por padrão é usado o renderizador por "Scanline". Vários níveis de Raytrace podem ser aplicados noPainel Raytrace, lembre-se que Raytrace consome mais memória do que Scanline.

Note Renderiazação de teste pode ser feita rapidamente com o comandoArquivo > Renderização rápida (F12) a partir do Animador ou do Designer.


Rotate Dialog

Diálogo da Ação rotacionar

Rotaciona vértices selecionados em volta da posição do Cursor3D Via um ângulo numérico.

Determine se a rotação será em sentido-horário ou anti-horário em relação ao Cursor3D na vista ativa.


Scale Dialog

Ação escala

Escalona vértices ou faces pelo fator numérico.

A expansão pode ser opcionalmente atribuída ao eixo Z (Superior/Inferior), Y (Anterior/Posterior) e X (Esquerda/Direita)

Vértices - Escalona os vértices selecionados a partir da posição do cursor3D ou do centro dos vértices selecionados. Esta é a opção mais comumente usada.

Faces - Escalona as faces selecionadas sem afetar o tamanho do modelo por inteiro.

A partir do cursor - Escalona os vértices ou faces selecionados realativamente a posição do Cursor3D.

A partir do centro - Escalona os vértices ou faces selecionados para o centro dos mesmos.


SFXpluginBlistersTX

Textura borbulhas

Essa extensão simula a aparência de borbulhas aleatórias na superfície onde é aplicada. Há algumas definições para alterar tamanho e repetição da mesma.

Lembre-se que o arquivo .DLL e .TFX das texturas precisam estar no subdiretório "textures".

SfxTextBlisters.gif (18480 bytes)

Uma boa forma de aprender a usar as extensões é fazer experimentos com as definições para resultados interessantes como os abaixo:

sfxtextblisters2.gif (10016 bytes) sfxtextblisters1.gif (24023 bytes)


Shader Help

Texturas e previsualização de texturas

Textura são criadas na renderização.

Plana | A textura plana é a cor pura sem efeito nenhum na superfície.
Madeira | A superfície ganha a aparência de madeira. A cor primária representa a cor fria, a cor da textura a cor quente.
Mármore | A cor dos veios são atribuídas pela cor primária e o fundo pela cor da textura.
Granito | A cor primária mistura com o preto.
Luminosidade | Simula uma superfície fluorescente. Use-a em lâmpada, abjoures, luminárias, etc. para simular um objeto que emana luz.
Flash | Essa textura exibe a cor da face num brilho máximo por 5 quadros e um mínimo por 5 quadros.dando ao objeto uma ilusão de flash. Use por exemplo nas luzes de navegação de uma aeronave.
Relevo | A textura relevo é muito útil. Ela atribui a superfície uma textura rústica. A intensidade e tamanho vc pode definir pelo parâmetro usando o Indicador do parâmetro da textura.
Azteca | Essa outra textura de relevo representa a superfície com área planas entre os relevos.
Rugas | Uma textura de relevo com efeito de rugas direcionais.
Pontilhado | Uma mistura de pontos irregulares aplicado a superfície.
Agata | Uma textura que imita pedra.
Nuvem | Essa textura simula a aparência de nuvens. Não é afetada pelas condições de luz.
Matelado | Pequenos relevos espaçados e colocados aleatoriamente na superfície.
Combinado | Mistura a partir da cor primária até a cor da textura criando vários traços combinados que podem ser editados.
Madeira++ | Está é mais natural aparência de uma textura de madeira, mas a renderização é muito mais lenta.

Veja mais
Extensões de textura


Shader Lock Palette

Paleta trava textura

Define a posição do eixo da textura na localização do Cursor3D.

.

Trava o Cursor3D no manipulador superior esquerdo
Trava o Cursor3D no manipulador superior direito
Trava o Cursor3D no manipulador inferior esquerdo
Não funcional
Sair


Shader Types

Texturas internas

Textura são criadas na renderização.

Plana | A textura plana é a cor pura sem efeito nenhum na superfície.
Madeira | A superfície ganha a aparência de madeira. A cor primária representa a cor fria, a cor da textura a cor quente.
Mármore | A cor dos veios são atribuídas pela cor primária e o fundo pela cor da textura.
Granito | A cor primária mistura com o preto.
Luminosidade | Simula uma superfície fluorescente. Use-a em lâmpada, abjoures, luminárias, etc. para simular um objeto que emana luz.
Flash | Essa textura exibe a cor da face num brilho máximo por 5 quadros e um mínimo por 5 quadros.dando ao objeto uma ilusão de flash. Use por exemplo nas luzes de navegação de uma aeronave.
Relevo | A textura relevo é muito útil. Ela atribui a superfície uma textura rústica. A intensidade e tamanho vc pode definir pelo parâmetro usando o Indicador do parâmetro da textura.
Azteca | Essa outra textura de relevo representa a superfície com área planas entre os relevos.
Rugas | Uma textura de relevo com efeito de rugas direcionais.
Pontilhado | Uma mistura de pontos irregulares aplicado a superfície.
Agata | Uma textura que imita pedra.
Nuvem | Essa textura simula a aparência de nuvens. Não é afetada pelas condições de luz.
Matelado | Pequenos relevos espaçados e colocados aleatoriamente na superfície.
Combinado | Mistura a partir da cor primária até a cor da textura criando vários traços combinados que podem ser editados.
Madeira++ | Está é mais natural aparência de uma textura de madeira, mas a renderização é muito mais lenta.

Veja mais
Extensões de textura


Shaper Tool

Ferramenta Deformador

Distorce os vértices selecionados em contato com a superfície de uma ferramenta virtual esférica.

Atua em ambas partes interna e externa, como se estivesse trabalhando com argila.

Clique e arraste a ferramenta, os vértices selecionados dentro ou fora da esfera serão distorcidos. Use as teclas dos modificadores conforme a lista abaixo:

Shift | Altera a direção longitudinal. (Eixo Z)
Alt | Altera a direção latitudinal. (Superior/Inferior)
Ctrl | Altera o tamanho da esfera virtual de influência


Simplify

Simplificar

Reduz o número de vértices, arestas, e faces no objeto selecionado.

Duas arestas praticamente colineares encontrando-se num mesmo vértices serão reduzidas a uma se possível.

Faces adjacentes com um mesmo ângulo de plano serão unidas se possível.

Essa ação é muito prática depois de uma Operação Booleana.


Strutting

Modelando

Vamos entender o processo de modelagem usando a ferramenta Caneta ou o Lápis.

Desenhe uma curva como a apresentada abaixo usando a caneta.

Desenhe uma aresta entre os vértices 6 e 1 para fechar a curva. Clique exatamente sobre o vértice 1, caso contrário um novo vértice será adicionado e a curva não será fechada.

Com a curva da figura 1 criada, dê uma olhada na vista Câmera. A vista OpenGL não ira mostrar nada até que a curva seja facetada. Note que a opção cobertura de malha da vista OpenGL está desligada.

Crie uma aresta entre o vértice 2 e 6 com mostra abaixo. Com a caneta ativa, clique no vértice 2 e então no vértice 6.

Assim uma face será criada e será visível na vista OpenGL. Agora crie mais duas arestas para formar as faces desejadas como mostra a figura 3.

Depois disso, vc verá um sólido 3d na vista OpenGL.

Agora tentaremos um contorno mais complexo.

Desenhe uma letra "C" com apresentado abaixo.

Note que a situação é igual a anterior, vc tem um contorno não facetado, crie igual ao exemplo anterior as arestas que formarão faces seguindo o esquema abaixo.

A aresta marcada em vermelho é importante. Ela representa uma mudança no rítmo. Veja que a sequência da construção segue uma regra geométrica mas na aresta vermelha a sequência é quebrada. Note que o ângulo formado pelas arestas 12-11 e 12-7 é maior que 90 graus. A melhor escolha é manter o ângulo menor que 90 graus para evitar faces muito grandes.

Regra 1: sempre evitar faces grandes e compridas.

Não é uma proibição a princípio, o objetivo dessa regra é facilitar a manipulação de objetos posteriormente.

Regra 2: Nunca, nunca tenha faces sobre outras.

A Figura 10 demonstra com o que quatro faces sobrepostas aparecerão. Nunca desenhe uma aresta passando por cima de outra.

A Figure 11 mostra a maneira correta e perfeita para fazer o mesmo arranjo.

A Figure 12 mostra como uma simples aresta pode criar o mesmo arranjo da figura anterior.

Claro que o Render vai eliminar qualquer problema da figura 10 na imagem final, mas é um estilo muito ruim de criar objetos. Vc sentirá isso quando tiver que fazer uma modificação no modelo ou uma morfose.

E lembre-se, quanto mais faces usar mais memória irá gastar.

Finalmente, como fazer buracos.

Toda face que possuir mais que 3 vértices é vazada. Portanto numa face triangular com a demonstrada abaixo no interior do "A", basta criar uma aresta extra do centro para a extremidade fazendo com que o triangulo interno possua 4 vértices tornando-se assim um buraco.

Veja a próxima demonstração de como criar uma forma válida com um buraco no centro para uma extrusão.

Crie as arestas para formar as faces.

Note que o centro possui cinco vértices não ligados por arestas formando assim um buraco. Quando vc extrudir essa forma ela se parecerá um tubo.


OpenFX Support Site

Support Site...

Call through the WWW to the support site.


Tesselate

Tecelar

Divide cada face selecionada em três faces adicionais criando novas arestas até um vértice no centro de cada face.

Antes da tecelagem

Depois da tecelagem

Contraste esse tipo de subdivisão com a ação subdividir.


Text Hold Point

Ponto de influência

Define o eixo de rotação para a fonte.


Tiling Types

Tipos de repetição da imagem
Padrão Cópias adjacentes do mapa irão aparecer lado a lado.

Mosaico Cópias adjacentes do mapa irão aparecer espelhadas nas direções, é muito útil para evitar aparecer as linhas descontínuas de um mapeamento padrão.


Trouble Shooting Tips

Dicas de resolução de problemas
Problema | Causa e resolução
Manipulador de mapeamento não está travando num vértice específico. | Mais que 3 vértices estão selecionados. Deselecione-os e selecione somente aquele correspondente ao manipulador. 3D Cursor não está indicando um vértice. Coloque o cursor3D mais próximo do vértice e pressione F2 para travar no vértice desejado.
Aplicação cai quando manipula NURBS | Incompatibilidade com a placa de vídeo ou driver mal instalado. Deslique a vista OpenGL.


TTF Text Builder Utility

Utilitário de criação de texto True Type

Possibilita a criação de texto 3D para logotipos usando fontes TTF.

Previsualizar forma -Mostra a forma da fonte.

Visualizar pré-arquivo - Previsualiza o resultado da projeção do texto 3D.

Ponto de influência - Define o eixo de rotação da fonte.

Botão Escolher - Seleciona a fonte TTF.

Texto - Entre aqui o texto desejado.

Chanfro anterior - Coloca um chanfro na parte frontal das letras.

Chanfro posterior - Coloca um chanfro na traseira das letras.

Ângulo do chanfro - Define o ângulo do chanfro, que dependerá do tipo de fonte de forma a evitar interseções que causarão falhas na forma.

Profundidade do Chanfro - Define o tamanho do chanfro.

Largura - Define a largura da fonte.

Preencher anterior e posterior - Gera uma superficie nos lados frontal e traseiro da fonte.

Não preencher - Gera a fonte com buracos.

Mostrar da esquerda para a direita - Cria os caracteres na forma de leitura normal. Exemplo: Logo

Mostrar da direita para a esquerda - Cria os caracteres na forma inversa de leitura. Exemplo: ogoL

Defina também a cor da fonte e do chanfro e pressione criar.

Fontes símbolos podem criar formas interessantes


Using Help

Usando a Ajuda

Explica como usar o sistema de ajuda.


WindowBox

Vista de trabalho

São as vista onde vc irá trabalhar.

Superior | Olhando de cima para baixo
Anterior | Olhando de frente
Lateral | Olhando da direita para esquerda e vice-versa

A vista câmera (superior direita) é uma renderização 3D com perspectiva.


Postprocessor Atmospherics

Pós-processo Luz-Volumétrica

Cria um efeito volumétrico no cone da luz spot. Ele é controlado através da caixa de diáloga abaixo

Aviso: calcular esse efeito é muito demorado, portanto escolha cuidadosamente as opções aqui

SFXplugAtmosXX1.GIF (45198 bytes)

A primeira coisa a considerar é que há dois tipos de efeitos atmosféricos cobertos na caixa de diálogo:

  1. Uma simulação detalhada do efeito volumétrico envolvendo um tempo de calculo alto e ajustes finos nos parâmetros que requerem experimentação para que vc consiga o resultado desejado, esses parâmetros são Amostras, Neblina superdensa, Sombra extra-forte e Atenuação máxima.
  2. O segundo tipo é uma aproximação instantânea que não envolve muito detalhamento e cálculos. Para usá-los habilite a caixa Usar efeitos atmosféricos e escolha o tipo de efeito (As outras opções não afetarão esses efeitos).

Os efeitos trabalham em conexão com as luzes do tipo Spot, vc pode especificar qual luz será afetada pelo efeito.

Tipo de efeitos volumétricos
Vamos comparar os efeitos com uma simples luz spot sobre um objeto como representado abaixo:

SFXplugAtmosXX3.gif (13723 bytes)

Agora vamos adicionar o efeito chamado "Raios de luz" que apresentará um resultado semelhante a este: (lembre-se de ticar a caixa de efeitos volumétricos)

SFXplugAtmosXX4.gif (17132 bytes)

Esse tipo de luz representaria bem uma atmosfera num dia frio com as luzes entre as árvores ou imagens subaquáticas.

Agora vamos aplicar o efeito "Vento" :

SFXplugAtmosXX5.gif (17368 bytes)

E agora vamos tentar o "Poeira":

SFXplugAtmosXX6.gif (25039 bytes)

Por fim o efeito "Fumaça" :

SFXplugAtmosXX7.gif (17330 bytes)

'Integração total da luz volumétrica'

Para obter um tipo de luz volumétrica super real teremos que usar o Raytrace. Claro que usando esse recurso o tempo de renderização aumentará consideravelmente. Quanto maior o número de amostras maior o tempo do Render.

Outro controle é a aparencia da neblina. Basicamente são Neblina superdensa e Sombra extra-forte.

Para vermos como as amostras trabalham, analisemos os exemplos abaixo:

Uma luz sem efeito aplicado:

SFXplugAtmosXXfull0.gif (8305 bytes)

Renderizando com 32 amostras e os valores para: (Neblina superdensa)=0.0 (Sombra extra-forte)=0.0 (Atenuação Máx.) temos:

SFXplugAtmosXXfull1.gif (17293 bytes)

Reduzindo o valor da Atenuação máxima para 0.25 reduz a densidade da neblina assim:

SFXplugAtmosXX9.gif (15670 bytes)

Usando (Sombra extra-forter)=1.0 teremos: (Para um cena mais natural o valor apropriado é 0.0:

SFXplugAtmosXXfull2.gif (17729 bytes)

Por fim usando (Neblina superdensa)=1.5

SFXplugAtmosXXfull3.gif (12077 bytes)

Veja esses outros exemplos:

No exemplo abaixo 16 amostras são usadas com Neblina superdensa a 3.0:

SFXplugAtmosXXex1.gif (32682 bytes)

SFXplugAtmosXXex2.gif (31154 bytes) SFXplugAtmosXXex3.gif (31471 bytes)

No exemplo abaixo (atmos_full_ex3.stg) um pós-processo neblina é combinado com a luz volumétrica. Note que vc pode ver a luz atravessar por um dos buracos do objeto (a partir do quadro 3) o rastro é renderizado na cor da neblina.

No último exemplo (Atmos_full_ex4.stg) um intenso efeito de luz atravessa um objeto com valores de Neblina superdensa 1.0 reduzindo para uma atenuação máxima de 0.5.

SFXplugAtmosXXex4.gif (47471 bytes) SFXplugAtmosXXex5.gif (32447 bytes)

Comentários:

  1. Quanto mais áreas da tela forem cobertas com a luz volumétrica mais demorado será a renderização. Veja no exemplo abaixo que a luz está um pouca abaixo da aeronave vindo em direção a câmera o que levará a um tempo muito grande de renderização:
    SFXplugAtmosXXA.gif (38398 bytes)
  2. Faça experimentos usando resoluções mais baixas. Veja os exemplos que acompanham o progama.
  3. A extensão de luz volumétrica ésta na subpasta Postprocess sob os nomes ATMOS.XFX e ATMOS.DLL.
  4. Os 'Efeitos volumétricos' são mais velozes, use-os sempre quando for apropriado.


Post Processor FireballPlugin

Bola de Fogo

Essa extensão gera bolas de fogo fractais e explosões.

Como essa extensão trabalho com elementos animados, é melhor usada como um ator de efeito (FX).

Essa extensão é controlada pela caixa de diálogo abaixo:

fireball1.gif (47745 bytes)

Igual aos efeitos Auréola e Reflexos de lentes a Bola de Fogo é amarrada a uma luz. Ela pode ser amarrada a uma luz normal associando-a com um cubo limitado. Agora éssa é a restrição principal:

A luz onde está amarrada a bola de fogo precisa ter sua origem atenuada

Se vc tentar usar uma Bola de fogo com uma luz não atenuada éla não funcionará. A razão de usar uma luz com atenuação é para indicar ao Animador que a esfera que define a atenuação define a intensidade da bola de fogo ou explosão. O efeito usa essa esfera como um container para confinar a bola de fogo no seu interior.

Veja um exemplo do resultado espetacular desse efeito!

XFXfireball2ps.jpg (7203 bytes)

Clique aqui para ver uma imagem maior

Controlando o efeito:

  • Chamas
    Quando esse botão estiver ticado a aparência será como a imagem da direita.
    temp.gif (12904 bytes) temp1.gif (21608 bytes)
  • Explosão
    A explosão irá gerar bolas de fogo que irão aparecer e dispersar em fumaça no final da animação.

Definições da luz
O efeito pode ser aplicado a todas as luzes na cena ou a uma luz especificada.

Cores
Existe 3 definições. A escuridão é usada para a cor da fumaça, a do centro para o coração da bola de fogo e a externa para as extremidades da chama.

Suavização da granulação
Veja no esquema abaixo o que a suavização pode fazer. Coloque os valores na caixa para o efeito desejado.

temp.gif (48513 bytes)

Densidade
Use para definir o brilho, veja a ilustração para ver o que certos valores podem causar.

temp.gif (35054 bytes)

Regularidade
A regularidade (Padrão 0.2) determina como a explosão vai aparecer. Um valor de 2.0 é próximo a uma perfeita esfera (ou uma estrela)

temp.gif (33016 bytes)

Alcance vertical
Use em conjunto com uma chama para simular uma fogueira, por exemplo. A imagem abaixo usa um valor de 3.

temp2.gif (8497 bytes)

Expansão
Quando este valor é o padrão então o tamanho da esfera envolverá a bola de fogo. Se vc deseja que a bola de fogo ocupe um espaço maior ou menor, altere esse valo.

Amostras
Controlam a qualidade da integração fractal, um valor alto aplica mais detalhes na bola de fogo, mas aumenta o tempo de cálculo. Um valor abaixo de 4 pode dar uma boa aparência a bola de fogo.